FMS database not updating in Prepar3d

I don’t understand what I am doing wrong. Above, I’ve placed links to screenshots where I show that I’ve updated my Majestic Dash8 Q400 and then the FMS in the Majestic showing a 2017 (outdated) database.

When I try to load a flight path in to the FMS, from SimBrief, it can’t find waypoints. I presume that the reason for that is because of the outdated database. I am obviously doing something wrong and I just can’t find the answer; Perhaps because I don’t really know what to look for. I thought the purpose of the Navigraph FMS Data Manager was to update the onboard FMS in the aircraft. Is it not?

Am I barking up the completely wrong tree? How do I update my aircraft FMS to recognise current waypoints from flight plans?

please can you confirm, that you are still on the old Prepar3D v3 … is this correct? Currently the version is v5 … only just to be sure because in your FMS Data Manager screenshot you have P33 in the Majestic line, which means you are using P3D v3 … P34 = P3D v4 and P35 is P3D v5 …


Yes. I have Prepar3d V3. So, I can’t use Navigraph?

For sure, we support the Majestics in all versions independet of which sim-version you use. It was only a little bit strange for me and therefore the question. I don´t have P3Dv3 installed so, I can´t really reproduce it …

So, first of all please post a screenshot of your settings page in the FMS Data Manager to look if your P3D root path is correct so far:

Further a screenshot of your Majestic Addon Mapping - move your mouse over the path in the Addon-Mapping page that you see the whole path

… and last, please upload the screenshots directly here in the forum and not somewhere external via link. A description, how you can do this - do you find here

Thank you,
This first one, I added the window to the side because the entire path wasn’t legible in the main window.
I had an issue with this second one too. But, the paths are visible in a round-about way.

Again, please upload the screenshots directly here in the forum and not over your own cloud … when you delete the screenshots, this posting is useless because no one can open the external links then - so please try to upload the screenshots here directly

The paths looks good. So, can you check if the files are installed correctly now?

So please go into your P3Dv3 root path:
under SimObjects\Airplanes\mjc8q400\nav

Here you should see a cycle_info.txt file … it´s a simple text-file. Can you open it and can you look what AIRAC version you see here?

As an example like mine:

Do you see 2203 or any other cycle number?


Actually, there is ‘something’ interesting in that folder. I think I might see something related. I’ll go gather screenshots.



All of the files in the first screenshot are dated to 2022. However, the file nd.db3 is dated to 2017. That is the same year that the onboard FMS says that it’s database expiration is.

That is exactly the reason …

Try following:

  1. close the sim (if open)
  2. close the FMS Data Manager (if open)
  3. delete all files in this folder (excluding your routes-folder)
  4. open the FMS Data Manager and click on the Majestic line and again on the Update-button (this should bring all files back in the folder
  5. look again in this folder and look if you have ONLY these files:

The 9909ad0f-... file is exactly the nd.db3 file and it looks, that this file (nd.db3) was blocked during the installation (can be happen when you have open the sim during the AIRAC updates).

So, please follow the steps above and all should be good


1 Like


Thank you very much, Richard! I am very pleased. I was confused and frustrated but you worked out my problem for me and fixed it in such a short time from when I asked for help.

1 Like

Great, you´re welcome … no problem, it´s part of our service … So, whenever you have an issue, a question, please let us know - don´t hesitate to contact us.

Have a nice evening - my day here in Austria starts after this kind words wonderful :slight_smile:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.