Error - Unable to Communicate with the Server - Simbrief Downloader

After installing the latest update I receive the above message. Have checked the Firewall and confirm the Program is accepted. Have tried many times over the last week. The Forum has covered this problem before, but some time back. Any suggestion?

Hi,

Indeed, I had spoken with one other user in the same part of the world who had a similar issue recently. Maybe you’re running into the same problem as them.

The issue was that when connecting to the SimBrief server, they were seeing abysmal download speeds (only a few KB/s), whereas normally their download speed should be around 50 MB/s. This seemed to be occurring any time they were downloading or connecting to a website hosted in the same part of the world as SimBrief (Eastern Canada). Unfortunately these slowdowns aren’t something we have any control over, it would instead be your ISP that would need to investigate why they’re having issues connecting to this part of the world.

Slow download speeds can trigger a “communication error” message in the SimBrief Downloader since it misinterprets it as the download timing out. One workaround that should work is to generate your flight plans with the “Flight Maps” option set to “None”. This will significantly reduce the file size of your flight plan and should prevent the timeout error you’re seeing when using the Downloader.

If you’d like to test whether you are in fact seeing slow download speeds as well, you can do the following test:

  1. Go to https://www.speedtest.net
  2. Below the “Go” button, click “Change server” (it may take a few seconds for this option to show up)
  3. In the search box, type “OVH Cloud” and choose the “Beauharnois, QC” server
  4. A bit further below the “Go” button, under “Connections”, click “Single”
  5. Click “Go” to run the test and check what speed you get
  6. If you aren’t sure what download speeds you normally get, you can also run a speed test using default settings for comparison (which should automatically select a server that’s closer to your location)

Best regards,

Hi,

Firstly, thank you for the prompt reply.

I will test the download speeds when I use my flightsim computer at the weekend, as it uses a different internet provider to my work/weekday setup. Am I correct in thinking that the Simbrief web page is on the same server as the Downloader? With one exception (A white screen with “GATEWAY Error”) I have not had any problems logging on and generating flight plans.

Best regards,

Peter

Yes it’s the same server, but the Downloader is downloading a much larger file than during normal website browsing.

This is why generating your flight plans with “Flight Maps” set to “None” is an effective workaround, since it reduces the size of the file that the Downloader needs to download considerably.

I have exactly the same error for the past 24 hours. My internet speed is very good at this end. Is there a problem with the server?

1 Like

Me 2, sb downloader has no connection to server…

1 Like

Add me to that list too. I thought I would uninstall it and reinstall it again and so I have tried to download the downloader again only to be met with a painfully slow download speed to get it so something seems up with the server.

1 Like

Add me to the list also. Since a couple of days I got the same message of not connecton with the server. i don’t think it has anything to do with my server. I used the program for years without any problems, so if suddenly I get this problem and all other programs work fine logic telles me that the problem is not at my end.
pls look into this at your end.
Simsen

Add me to the list also, Cheers Stefan

same here. The downloader keeps trying to connect but to no avail.

Same here. Simbrief Downloader will not connect to server. Simbrief itself is accessible but not the Downloader app.

Hello,

I can confirm that the loading time is very slow the last two days. I saw this on different streams on twich and also expiriencing it myself. This I can’t download my plans right now I searched in the forums.

Since I know quite some bit about networking (I am responsible for two AS (As are the networks which makes the internet)). And since I do not have any issues to reach the OVH services I would like you to provide a test IP I can do some research on.

Until now I will setup a few tests with https://atlas.ripe.net just to make sure, that my ISP is not the issue.

I will try to post the results of my tests. Not sure if you can see them without a ripe.net account.

Kind regards

Downloader is ok again. :grinning:

Ok so here are some results. I used the host which I found in the console.log from the SimBrief Downloader.

https://atlas.ripe.net/measurements/34774156/#probes

and

https://atlas.ripe.net/measurements/34774152/#probes

So ping and traceroute from 10 random probes around the world show that www.simbrief.com is reachable. Even from Germany which is where I am located. Also some local teste with mtr, tcping curl -v -L show that I can connect to the server itself but the tools aren’t getting any data.

Next step is to check the output of the webpage while in Chrome debugging mode.

To be honest right now I does not look like a internet connection issue on my side. Maybe your technical team can say something or shoot me a message. I am happy to help with the debugging.

Kind regards

No for me.

@simbrief any load balancer / load issues?

Here is what I get after a few minutes.

23-08-SimBrief Downloader

But my ISP looks good.

1 Like

Since you ran into an issue with Let’s Encrypt certificates three months ago [0]. And Let’s Encrypt certificates are only valid for three month. Can it be, that this has something to do with it?

since I can’t fly as planed I will poke a little but around :slight_smile:

[0] Downloader unable to communicate with the server - #33 by disco79stu

If this helps to debug on your end: Navigraph Charts on the same computer loads the flight flawless. So i am pretty sure, that the problem with the simbrief downloader is not on my side.

Kind regards

I can confirm this too. Starting Simbrief Downloader and then it takes a couple of minutes. After that a message appears, it can´t connect to the server or my internet has issues (It says at least, but my internet connection is fine). Clicking retry does start the connection process again, without positive result. I am located in Germany (Frankfurt) and my InternetConnection shows 100MB Download speed

The same problem exists on my PC. SimBrief Downloader 1.6.3 window shows
always in a cycle

  • first “Loading” for a longer time
  • then “Waiting” for a longer time.
    That is all what happens after starting the SimBrief Downloader App