Simbrief Downloader server timeout

I read the posts from last December with people having issues with a server problem and it appears this problem is back again. Have not been able to download my OFPs for a couple of days now.

I have tested my download/upload speeds and they average around 450mbps

Hi …,


What happens when you create plan and press the Generate plan button?

Then what are you attempting that isn’t working? Screenshots help using Guide to posting Screenshots



Just tested it and now it’s finally working. To answer your question the program would show “LOADING” for a good 3 to 5 mins then display “unable to connect server” and ask to be closed.

If it happens again I will furnish screenshots. In my using SIMBRIEF for over 2 years this was the first time I ran into this issue.



Hi Kamran,

Glad it’s working again. If it happens in the future, one thing you can also try is to temporarily generate your OFPs with the “Flight Maps” option disabled. This makes the download size much smaller which can help if the connection slows down for whatever reason.

It’s possible there was a temporary network issue between your location and the SimBrief server that slowed down the connection or something.

Best regards,

I am also having trouble with the “error unable to communicate…” . This only happens on 1 of my 3 networked computers and after recent update to (which is on all 3 pc’s). I get the splash screen, then nothing else happens until the above error message. After a minute or two, I see the message, “Keep trying…” but when I click on this message, the app closes. I’ve tried the recommended solution to uncheck Flight Maps-actually only have detailed Navlog checked. Also, I have uninstalled and re-installed with no change. The pc that the app is not working on is a Windows 7 machine if that matters. Ran a speedtest and the internet speeds are very high (wired connection) I create the plan on another pc and am only using the Downloader on this particular pc.

Any help/guidance would be appreciated.