Sim link Not Working; Cannot get moving maps

Hello All,
So recently I purchased navigraph so that I can have moving maps and charts for my flying on MSFS2020. I’ve had the program before—though it’s been a while—so i’m quite familiar with the functionalities of the charts program. When I used navigraph about a year ago, I had no problems. Now, my sim link is not working properly. I cannot get moving maps no matter what I do: Launching MSFS2020 first, then simlink, launching simlink and then MSFS2020, or restarting simlink while MSFS2020 is running. Can anyone help? is anyone having this problem?



Please let us know how you get on.


Hello Ian,
Thank you for your response!
I have tried the above steps, and it is still not working properly. When I launch MSFS2020, I still cannot get the moving maps feature to work. I launch simlink prior to starting the game:

And it is still saying “cannot connect to simulator” when i’m in my plane spawned on the ground. When i installed navigraph originally it installed a “navigraph simlink”. This is the simlink i deleted when I followed your steps. I also made sure I installed the updated version of simlink. Why is it still acting up?