Continual CTD'S when using Navigraph in game panel - see attachment

I have had continual CTD’s which I have narrowed down to the Navigraph in game panel as the culprit.
Since deleting it from my community folder I have not had another CTD.

Please can someone help? How can I get the In game panel to not CTD my system?

Hello Jonathan! Welcome to the forum.

I presume that this error started appearing recently, as in one of the latest simulator updates? If that is the case, I would recommend you to follow these instructions on submitting a bug report for MSFS directly.

While you’re at it, it would be cool if you could post the dump files here as well in case they contain something that we at Navigraph can work with! At the moment though, this seems out of our control.

Sorry for the inconvenience!

Kind Regards,
Malte

Sorry for bumping this old thread but I’m suddenly having this problem and it seems to also be crashing MSFS when I attempt to reconnect/re-sign-in to the Charts application. All apps appear to be up to date.

Hello @eurekaiv ! Thanks for your feedback and sorry for the trouble.

It seems that SU9 came with a few regressions on ASOBO’s side which is causing all kinds of headaches for several developers, us included. For example, you can no longer sign in quickly by opening the link directly from the panel and, perhaps most importantly - the panel no longer persists the login despite us having fixed it recently (see the changelog).

Regarding the crash issues - we have so far not been successful in reproducing this, but we’re aware that the issue exists.

That said, I would advise you to follow the instructions in my previous post here. If you can send us the files, and perhaps even provide us with a list of steps to reproduce the issue, that’d be great! I would be very thankful.

Again, sorry for the inconvenience!

Kind Regards,
Malte

I probably won’t have time to troubleshoot much for a few days but I’ll report back when I can. Thanks!

I should also note that I was not using the in-game panel and I don’t have that plug-in installed. I use the Navigraph application open in it’s own window on a second monitor alongside MSFS.

1 Like

@eurekaiv The stand-alone Charts application cannot crash MSFS as they are not connected and are separate processes. The SU9 seems to be crashing a lot for users randomly, which is probably happening to you as well with logging into Charts at the same time just being a coincidence.

Kind regards,

Markus

Everything was working fine until I clicked the triangle to try and connect to the sim so I could see my progress on the map in the Charts app. Doesn’t this mean it’s connected somehow?

The simulator is connected with Simlink (through a network interface) that sends your position to our servers. When you click the triangle, the application just opens a connection with our servers, it is not directly connected with the simulator, and it is impossible for this action to cause a crash.

Most probably you are affected by the general problem that people are reporting in this thread MSFS Application Error - memory could not be read - #99 by mjchernis - CTDs - Microsoft Flight Simulator Forums

Kind regards,

Markus

What about the A32NX EFB? Since that seems to load Navigraph data into the sim somehow, maybe that was the cause of the crash. This is obviously a separate issue to the logging out constantly but it seems unlikely it would be a coincidence that as soon as I tried to reconnect the sim started stuttering badly and then gave up.

FWIW, I found a couple hours today and uninstalled/reinstalled the entire suite of Navigraph apps (Charts/Simlink/Navdata) and had no problems completing a short flight in the A32NX and didn’t experience the sign out bug.

1 Like