Connot find simulator

when i open the navdada installer

Hi,
I assume you have the sim from the MarketStore … correct? Or do you have a Steam Version?

Can you check, if this folder exists:
%localAppData%\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache

… or, if this folder exists:
%appData%\Microsoft Flight Simulator

… or does both folder exists?

Cheers,
Richard

Hi Richard. I’m also having exactly the same problem. I have tried to install in various different places to get it to work but no matter where it goes it says cannot find/access simulator.
I’ve tried to find the files that you have suggested in my C and D drives and they don’t seem to exist anywhere. Can you please inform me/us of what the next steps are we should take?

Many thanks
Bob.C

P.S Mine is the Steam version.

Hi Bob,
when you put this into your explorer:
%appData%\Microsoft Flight Simulator

Can you read this folder? Do you see a file called UserCfg.opt?

Additional, do you have installed the MSFS before (ie. as a alpha-version, or from SimMarket)?

Cheers,
Richard

I have the same problem, ever since I moved my appdata folder location using the Windows 10 tool to do so.

In the %appData%\Microsoft Flight Simulator Folder I see only another folder called packages which under a few subfolders does include only the pdf manual for Aerosoft’s EDDK and nothing else.

The other folder exists alright, the usercfg.opt is in there, it is correctly set, according to the FAQ post.
Yet still, the Navigraph Installer doesn’t see the MSFS installation and so I’m still stuck on cycle 2103.
Manually deleting it didn’t change a thing. And then I couldn’t even restore it from the recycle bin.
Why is this so complicated? All other installers can find MSFS fine, even after changing the file system, only the Navigraph program causes these issues

Hi Karsten,
two questions to this:

  1. You wrote, that you found both folder … that means for me, you had a Steam version installed also? Is this correct?

  2. Have you anytime installed any Alpha version of the sim?

Thanks for your help,
Richard

Hello Richard,

no to both questions.

Hi again Karsten,
we have released a new version now. You can download it here

Please let us know, the result if it works now … thank you very much!

Cheers,
Richard

Hi Richard,
unfortunately not.
The UI of the new version remains blank on the left where it says:
Installed simulators.

Hi Karsten,
to summarize and a short checklist:

You have the MicrosoftStore sim - correct?

You have a folder called %appData%\Microsoft Flight Simulator which is more or less empty - correct? (normally this folder is only for the Steam version - so the question is, which addon on your system has created this folder and what is also very strange, why is there only a PDF included? - sorry, but that doesn´t look normal and a little bit odd)

Next, when you open the %localAppData%\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache folder, you find the file UserOpt.cfg file - correct?

Are you able to open this file (with a simple text-editor like Notepad or similar else) and can you go at the end of this file where find the entry (the points are your path to your community folder):
image

This path (the dots) are the path to your community folder - correct?

You have only one entry of this “InstalledPackagesPath” - correct?

Last, when you look on the "Security tab of the File Properties of “UserCfg.opt”, has here all groups/names the “Full control” persmission set?
image
The same for your community-folder persmission - all should have at least “Modify, Read & execute, List folder contents, Read, Write”

In most cases, till now, such issues happened after a “moving process” of the sim - I assume some permissions will not be moved 100% correctly. We have no issues of user with a “normal installation” (means, use the default location or as I personal have, that I set the content folder immediately during the initial installation another drive). But those user, which has moved the sim in some way (via Win10 or manually), we see in every case a permission issue. And I´m pretty sure this is also your case …

Cheers,
Richard

PS: oh and you´ll be sure, that no other process blocks this UserOpt.cfg file (so you don´t have running the sim in parallel)?

Ok let me go through the checklist

Yes.
I moved my entire Appdata Folder from my C SSD (which only holds the OS) to another SSD because
the System SSD is only 60GB and I constantly run into space issues the more programs keep installing information in the AppData folder.
And I checked this again. Inside Microsoft Flight Simlator folder there is nothing except the Manual for Aerosoft’s EDDK. Odd indeed. But that is what it is

Yes. I can open this file. And the path indicated at the end points to my community folder. Or rather the Packages folder which includes both the “Community” and “Official” Folders.
(The same path for example is recognized by your FMS Data installer for the Aerosoft CRJ, which is installed in the Community Folder under “aerosoft-crj”).

And there is only one entry in the “InstalledPackagesPath”.
And I rechecked all the permissions again (probably for the 10th time now since this problem started and checking your FAQ on the issue :wink: )
Yes, they are all correctly set.

I also suspect it has to do with me moving the AppData folder, but all other installers I have come across since then have no issue finding MSFS and installing their stuff in the correct folder.
So the root has to lie somewhere in the way you programmed your executable and how it reads the file structure.
Are there registry entries I should check for?

Hi again Karsten,
no there are no registry-keys … but we guess that the “strange pseudo steam-folder” is the reason for the mess. You wrote, there is only a PDF inside. Can you try to rename this folder temporary to see, if this is the case or not? I guess, this folder will not be used by the scenery … it was simple an issue in the AS scenery setup, which save the PDF into the wrong folder (my personal assumption :-))

The “Navigraph Navdata Center” looks for the UserOpt.cfg file in the paths (Steam or Store). Now, when the Steam path is found but no UserOpt.cfg file, it looks that the app means that no sim is installed. Again, that´s currently only an assumption and it would be cool, when you can rename this “pseudo steam folder” for a test.

We will fix this in the next update, when this is really the case. Thanks for your help!
Cheers,
Richard

When you mentioned that me having this folder was odd, I already tried that.
Tried it again just for good measure (simply moved the whole thing to the trash bin).

Doesn’t change a thing.

Just an observation, although as I already mentioned, other installers don’t see that as a problem:
The folder that is being pointed to in the usercfg.opt is not an actual physical folder, because I installed MSFS outside my system drive.
It is a hyperlinked folder that points to the real location on another drive.
It always throws me off when a new add-on tells me it is going to install on the C drive and I fear running out of space.
But in reality the files go onto my D drive.
And that wasn’t a problem for your installer either before I moved the Appdata folder.
(And just in case you want to suggest moving it back: I can’t. There is not enough Space on the System SSD left.)

Hi Farlis,

It might be the “hyperlinked” folder that is the problem. The application is not a native application (as many other installers might be) but is a cross-platform solution using Electron. We, therefore, do not interface directly with the filesystem as we would have if the application was using the Windows API directly through C++. We might need to add some additional code so that the link is followed properly.

I assume that with “hyperlink” you are referring to a normal Windows symbolic link? Can you please mail your UserOpt.cfg file to me on markus.hamburger@navigraph.com and I will try to reproduce here.

Kind regards,

Markus

2 posts were split to a new topic: Simlink not connecting with MSFS

@m4rkus and @NAVData
Any progress on this?
I tried the latest v2 version of the v.24 installer and that also doesn’t work.

May I suggest in adding an option to the installer to point to the appropriate folders manually, in case the automatic process fails?

It is in progress with high priority, as soon as there is something to test you will be notified :slight_smile:

Kind regards,

Markus

Hi Karsten, when this is also been fixed - the automatic process doesn´t fail any longer. The good point here is, that all these paths are standardized what makes the support much more easier :wink:

Cheers,
Richard

Good to know.

Meanwhile I found that something in my installation must have gotten messed up somewhere down the line. Since I deleted the navigraph folder from the community folder I have ZERO navdata in my base sim. No procedures, no airways, no airspaces… nada!
So I just deinstalled the whole sim and I’m currently reinstalling it. I’ll report back whether that changed anything in regards to the problem we discussed here.