Charts Update and Reinstall

Greetings! I’ve been a user of Navigraph Desktop Charts for sometime now, but recently charts would not link with my X-Plane 11.50 Vulkan. I tried to update with no luck so I completely uninstalled it and installed a fresh copy of the latest version.

I tried installing it in the default location, installed in a location of my choosing, as Administrator, not as Administrator, used by me, used by everyone. Each time after the uninstall and reinstall, the application will start and comes up to the sign in screen. Once I click on sign in, it comes up with the notice of opening my default browser, etc. However, it never opens. It stays stuck on the sign in screen.

It’s probably something simple, but I need assistance, please.

Thanks in advance.


Try restarting Windows, disabling Antivirus then steps as above:

  1. Use Windows to uninstall Simlink.
  2. If they exist delete folders c:\Users\username\AppData\Roaming\Navigraph\Simlink and c:\Program Files\Navigraph\Simlink
  3. Download and install latest Simlink .
  4. If still an issue, as a test please run Chrome as your default browser
  5. If still an issue,please upload latest dlog and log from c:\Users\username\AppData\Roaming\Navigraph\Simlink\logs