Charts iOS not working on iPad iOS V 14.2

I’m not sure if I should have embedded this as a reply to windlooper’s topic or started a new topic?

Regardless, yesterday I subscribed to and installed Navigraph Charts on my desktop with no problems either installing or having it link to MSFS 2020. I then downloaded and installed the iOS app to my iPad. When I launch the iOS app I get the “What’s New in Navigraph Charts” screen, but when I click on the Login button I get an essentially blank / empty screen with the text “” at the top. Thinking I was missing something, I downloaded and installed the app on my wife’s iPad and went through the same process. On her device however, when I click on the Login button I am taken to the username and passwords entry screen and from there (once those items are entered) I’m in the charts screen. Success…on her iPad!

I have uninstalled and reinstalled the app on my iPad with the same blank / empty screen results.

I’m not sure if this issue is unique to me or if others are experiencing it?

I have an iPad (7th Generation) with sw version 14.2. My wife’s iPad is an iPad Air with sw version 12.4.9.

Hopefully you can point me in the right direction to solve my iPad issue.




Are these two devices connected to the same network/WiFi?

If you remove the app from your device and install again from App Store, does the problem remain?



All devices are on the same network. I have removed and reinstalled and the problem is the same


Both the previously mentioned iPads are on the same wifi network. I had checked yesterday and just checked again. I just deleted, restarted my iPad and reinstalled the app from the App Store. Same results as before with going to the blank / empty screen after hitting the Login button from the “What’s New…” screen.

I have also installed the app on my Google Pixel, which is on the same wifi network as the iPads, and it works fine.



I just did the update to iOS v 14.3 on my IPad, thinking / hoping that might fix something. I launched Charts with the same result (non-result) as before. I uninstalled and reinstalled Charts from the app store, restarting my iPad in between, and the result was the same.


I have verified that the app works as expected in 14.3 so it points to that there is something
with your network settings on the specific iPad that makes it unable to load the authentication
webpage on our servers. Can you please verify that DNS is the same as on your other iOS / Android units? Or use Googles DNS at and

Kind regards,


Navigraph says it’s a problem on there end. They are working on a fix

I confirmed that the DNS is the same on my iPad, my wife’s iPad and my Google Pixel. As suggested, I changed the DNS entries to and, and that didn’t fix the problem. I reset back to the original DNS entries and the problem still persists.


That’s really weird. Can you just try to enter in mobile safari and see if you get a white screen as well or if an error message shows up?

Kind regards,


Tried that in Safari, Chrome and Edge with the same results being:

Server Error
403 - Forbidden: Access is denied
You do not have permission to view this directory or page using the credentials that you supplied.

Mind you, I never get to the screen that lets me put in my username and password!


I was told by navigraph that it is a problem on there side. Nothing we can do but wait for a fix. No time frame on the fix

Thanks. I’ll keep my eyes open for an update on the forum or an update to the app itself via the app store.

Guys, perhaps it not obvious, but I am one of the iOS engineers working at Navigraph :slight_smile:
When this white screen opens, there should be a share button on top of the page, can you click that button and paste the URL that is in there for me?

Kind regards,


Markus, I figured you were a tech guy :slight_smile:

When I click on the share button, the url that it wants me to share is:


I haven’t seen any action related to resolving my issue, with the last post I made being back on Dec. 14th.

I have tried a number of things to force this to work on my iPad, with no luck. I have changed default browsers, installing (in addition to the using the native Safari browser) Edge, Chrome and Firefox. I have cleared cache, history and data. You name it, I have tried it, and all with the same non-result.

Every day, in the hopes that like SoCalPilot, who indicated under his “No Map on iPad” post that it all of a sudden worked, I launch (and re-launch and re-launch) the Navigraph Charts application with no luck. As indicated before, I have (on numerous occasions) uninstalled the application, restarted my iPad, reloaded and ran the application – still with no luck.

If it helps at all, the content of the error message I get when I click on the compass like icon in the screen that appears after hitting the Login button in the ‘What’s New in Navigraph Charts’ screen is as follows:

“There is an error determining which application you are signing into. Return to the application and try again.”

Note that I am able to get to the charts on my iPad by entering into the browser, so all is not lost…but it would be nice to be able to use the native iOS application.



Hi. I have had no further response from navigraph either. Please keep me in your loop and I will as well. Thanks

Hi Team,

We are having difficulties reproducing this iPad problem affecting two users. We shall continue investigating. In the meantime please use


Thanks for the response. It certainly is strange that this is only impacting a couple of iOS 14.2 users!? If I get bored over the next few days, I might do a factory reset of my iPad and make Charts my first app install.


I am also having the same problem and tried all the same fixes. Still not able to log on. I was using it with no problem over the previous year then didn’t use it for awhile and when I tried to use it last week it won’t let me log on



Unlikely an issue, but can you check you have IOS V 14.3.

Can you log into ?