Charts iOS not working on iPad iOS V 14.2

Test I have v 14.3. My issue is a little different than the others. I can’t log into my desktop Mac Pro for navigraph. It loads but won’t display the program on the screen. It does work on sim toolkit pro app. I can use the chart.navigraph.com app independently but the moving map function will not work. Should you wish I can give you access remotely to my computer. Leonard

I do have iOS 14.3. And yes I can log into the web site. Only the app won’t show login, only blank page.

Hi Leonard,

Do you have an issue with Charts for macOS (Desktop) or Charts for iOS (iPad) or both? You have posted in both Categories.

Cheers
Ian

Okay, so I have fixed my problem with not being able to log into Charts on my iPad V 14.2.

I went into the Safari app from the iPad’s Settings on my home screen. From within the Safari setup screen, I opened the Advanced screen (Advanced was at the bottom of the Safari setup screen) and turned on / enabled JavaScript. I backed out to the home screen and ran Charts. I was - as was the case in the past - presented with the ‘What’s New in Navigraph Charts’ screen with the Login button. I tapped on that button and low and behold the screen came up asking for my Navigraph user name and password. Once both of those were entered, things began loading up and I was in!!!

I have fired up the app a couple of times with no problems and when connected while in MSFS 2020 everything appears to work fine. I can see my aircraft’s position the map, load charts, see my Favorites, etc.

Hopefully this turning on / enabling JavaScript in Safari fixes the problem for others.

Art

1 Like

That’s rally great. I am excite to try that to fix my issue. I will advise once I have tried it. Thanks very much for your great input

Interestingly enough, I checked my wife’s iPad - on which Charts worked from the get-go - and JavaScript was enabled. Guess that is why it worked on her iPad and not mine.

Good luck and I’ll be anxious to hear if that solved your problem.

Hello. My issue is with Mac OS on a desktop. I tried your fix but no luck. Oh well. Glad your problem is solved. Thanks for keeping me in the loop

1 Like

Hello,
is there a Navigraph Charts App for IPhone?
I switched from Samsung to Apple and now i’m wondering that i can’t download it. Thanks for your help!

I know this post is old, but I also struggle with this.

I am a network engineer and the fact that someone mentioned DNS sparked my attention.
Yes, ofcourse there is a lookup for charts.navigraph.com but if my DNS is functioning properly why would you search there?

Well, at first I thought it was my ipad, then I figured my desktop also has the same issue.
And to top it off, my cellphone too. I figured it could be a problem with the Navigraph service so I turned of Wifi on my cell phone and the page loaded.
Yes, Definitely not the navigraph service, must be my home network then…

I removed my custom DNS settings, set it to Cloud Fare and Google Public DNS and removed my domain name. Release/Renew ipconfig and the NSLookups showed 4 public IP addresses.

Non-authoritative answer:
Name: charts.navigraph.com
Addresses: 65.9.73.112
65.9.73.10
65.9.73.33
65.9.73.60

Still the page loads blank on my PC and it appears empty on my ipad.

Did anyone find a solution?