Charts app crashes and/or freezes since 8.22.0

Hi Team,

Charts iOS Ver 8.23.0 has been released. Please download and advise if your issues are fixed. As Richard says please advise iOS Version and iPad Version.


Excuse me, it it keeps freezing and having the same problems basically the update is not having results I don’t know what is happening my iPad is updated to last iOS version and the app is already updated to last version you recently released, the problem is just in the app of IOS because if you enter in an android tablet or in the pc or in the iPad but in safari browser it works perfectly. It so important to us to receive an exactly diagnosis and solution coz most of us work as a instructors or just students making their training in simulator using the app.

Hope a soon reply and solution tks

We can reproduce the issue intermittently and are working on it.

In the meantime you can access Charts Cloud at


This damn app is worse now than on the weekend. It now CTD. Seriously, what are you people doing with this program? I’ve downloaded the latest version 8.23.0 and it immediately crashes. I’ve shut down my iPad, I’ve removed the app three times and reloaded and it still dumps me out. I still get the offline screen momentarily. I go back into the app and if it doesn’t CTD, it freezes.

I’m running iOS 16.3.1 and is an iPad Pro 12.9 ML0G2X/A.

There are still problems with 8.23.0 - CTD and freezing as I reported over the weekend and per my entry below.

I have the same problem with my iPad Pro 12,9" 3rd Generation iOS 16.3.1

Many thanks for resolving the bug.


We have identified this issue and are currently working on a fix. It will be available in the next update 8.23.1, but as we need to wait for Apple’s review (which can take 24-48 hours) we recommend those affected by this to use the web app in Safari on your iPad in the meanwhile.

Sorry for the inconvenience caused.



1 Like

Thanks for responding so quickly.

Update - I am still having CTD issues with the latest version 8.23.1. Just downloaded the updated version, logged in, and then it crashed. Open the app again, it crashed. Tried a third time, it crashed. Is there a rogue bit of code lurking somewhere because I haven’t done anything to my iPad OS (16.3.1) as the app was working fine before these latest updates.

Is there any chance of being able to download an earlier, stable version for IOS?

Dang, How I hate to be inconvenienced by a snag in an update to an amazingly awesome free app. :joy: grateful! Thanks.

I hope update will be out soon because the app is totally useless due to freezes and crashes. I am on iPad Pro 11" 4th generation iPadOS 16.3.1 for your information. Thanks and best regards

Hello everyone! We believe that we have a fix since we are no longer able to reproduce this. We will now submit a new version (8.23.1) to Apple, but as @stephen has already mentioned it won’t be immediately available due to their rigorous review process.

Thank you for your patience so far, and sorry for the inconvenience!

Good news! We were able to get an expedited review process and the app has now been released.
Please try out the new update and let us know how it works out!

Kind Regards,

Seems to work normally again, crossing fingers it will remain stable.


just came across this thread after expericing the same issue with the app crashing / freezing and found this article on my iPad gen 9 with iOS 16.1.1 (20B101)

Updated the app to V8.23.1 build 1 and it’s no longer freezing / crashing as before.

1 Like

Thank you for the reports guys! We’re happy to hear that the situation seems to have improved.

Please keep 'em coming, good or bad!

Kind Regards,

the new version seems stable so far, however, I noticed that the simlink app is still intel only code. Not sure why that is but seems odd that a universal plug-in would require an intel only app to communicate with an iPad ARM app. And why would I need to run rosetta in the background just for simlink. That just doesn’t make sense to me.

Thank you for the feedback! It is much appreciated!

Regarding Simlink, let’s keep the discussion in this thread:

I have tried this for a few flights and seems much better indeed.

Many Thanks

1 Like

Hey There!
I still have issues on iPad M1 Pro, 16.3.1 with v8.23.1 build 1 - still freezing on loading charts on an import of simbrief, if simulator is open and simlink is connected. Clicking on the pinboard and switching throgh charts is leading into crash/freeze of app.

The issues you are seeing are more than likely not related to the original issue in this thread. Please see the post below and follow the instructions. This way, we can gather more information about the issue!