Charts 8 In-Game Panel Beta Testing

Yes I am using the ‘windows’ style window minimise/maximise at the top of the panel as it was fine with older panel. I have just tried the CTRL+N and it is a bit better. I’ll use that in the future. Thanks.

A post was merged into an existing topic: Switching rendering mode (2D/VR) results in sign-out

A post was split to a new topic: Unable to pan charts, scrolling works

A new OTA update has just been released and will be automatically loaded the next time you open the panel!

This version contains two improvements to the panel experience:

  • Route elements now scale and should look better on higher resolutions. (topic)
  • Stutters when using moving maps should be greatly reduced (topic)
  • Random signouts should no longer occur (topic)
  • Panning the charts should now be possible again (topic)

Thank you for your much-appreciated feedback, everyone! We hope you’re enjoying the beta so far, and we’re looking forward to getting the new version out of beta.

Kind Regards,

1 Like

What a great update Malte!

One thing I still struggle with and I’m pretty sure I already reported it but can’t recall if it was in this thread or in a separate thread. When having more pinned charts in VR to fit the window size, even when it looks like a scrollbar at the bottom of the window, I can’t move it using the mouse.

As I recall it, one suggestion was to make the window bigger. That of course can work if there’s only one or two charts not fitting. At the same time, it’s not an optimal solution since you don’t want the window too big in VR. That makes it hard to know where to place it within your VR space to not obstruct too many other things when you have the window open.

Having a working scrollbar would be ideal but if that is not possible due to some MSFS limitations for these VR in-game panel windows, maybe you could add the same custom arrows you have at the top of the window. That allows you to move all the way to the left (your origin) or to the right (your destination. That I think could work also in this case.

Other than this, I’d say what we have now is really top notch!

Do you think that this struggle would be solved by this? If so then that will be done, as soon as we have the resources to do so. Not sure that will be before or after we get out of beta though!

Thanks, will check it out.

Another issue I’ve reported in the past where you mentioned here how it would be fixed in next update.

Not sure what update you were referring to but I just gave it another go and still get the same error message when trying to auto-generate a route after having picked the active runways for my origin and destination.

Hmm, I am not able to reproduce. Let’s reopen the topic!

Very happy to have found out it’s actually possible to move the scrollbar in VR. I thought it was impossible.

What I learned is like that other guy said it’s very important you’re in the exact correct location with you mouse cursor before you try to drag the scrollbar left/right. It seems like you need to have the tip of the arrow just above the upper edge of the scrollbar.

Absolutely brilliant, thanks for pointing me in the right direction!


OK, that’s odd.

I just tried it not long ago, putting in LICJ rwy 25 as my origin and ENVA rwy 27 as my destination and the autoroute feature fails. Removing the runways, all good.

Great looking firward to trying the new update.

How can I tell if the OTA update is working? I looked at the folder with the beta panel and all the files are dated 12/21/2022. Is there a new version number? Mine is 8.17.0 build 1.


1 Like

That is the latest update! The OTA update will not change any of the installed files.

Thanks much! Did not realize it was all server side.


It isn’t all server-side, however most of it is. Some things will require manual updates of the panel, but if that would be the case we would let you know!

so when will the final verson be relased?

We don’t have a date, it will release when it is ready.

What you have now is the release candidate. If we would release today it would be this one. We don’t have another version in the works, the release candidate/beta is the latest.



Been struggling the last few weeks with intermittent CTDs. Where I’ve been trying to figure out what’s causing them. Which isn’t an easy task based on the very sparse information found in the Windows Event Viewer Application log.

A couple of days ago, I decided to move out anything not absolutely necessary from my Community folder and then start adding them back. One by one.

Tonight and after a number of successful flights the last few days with one of them about 3:30 flight time and with no CTDs, I decided to add version 8 of the in-game panel back. I actually was able to make a short hop earlier today without any issues.

After this though, I’ve made two attempts to fly LFKB-EBBR. First attempt, I had a CTD when I was approaching my TOD. Figured it was the Aerosoft EBBR scenery causing the issue or some of the extra Aerosoft modules to handle the jetways at some of their airports. Since these were the last I added back to the Community folder. I decided to get rid of the extra modules for jetways and just keep the actual EBBR scenery. Then I made attempt nr two. This time, I had the CTD even before I was able to do the pushback.

Since I find it a bit long-fetched the EBBR scenery would cause a CTD when I’m still on the ground in Poretta, I’ll now try going back to the in-game panel 1.3 again and see if I have any more success. Since the in-game panel version 8 was the last thing I added back before the Brussels stuff. Also based on how I was able to do a number of flights the last few days without any issues.

With this said and back to where I started, it’s very hard to know for sure what the actual culprit is when the issue is intermittent in combination with how the information provided in the Application log doesn’t really say much. Other than flightsimulator.exe caused the crash.

I guess at this time, I just wanted to ask if you had any other reports of crashes from people using the beta of the in-game panel? I did a quick search myself a few days ago but wasn’t able to find anything that would suggest this is a known or common issue. So this is just me keep looking for a needle in a haystack…

This is what I see every time I have these CTDs:

Faulting application name: FlightSimulator.exe, version:, time stamp: 0x00000000
Faulting module name: FlightSimulator.exe, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000001543e15
Faulting process id: 0x0x3D04
Faulting application start time: 0x0x1D92DC090F99428
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.29.30.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.29.30.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Report Id: a37f346f-db24-48af-8a22-9d1235807723
Faulting package full name: Microsoft.FlightSimulator_1.29.30.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

Followed by this:

Fault bucket 1410997449907262409, type 5
Event Name: MoAppCrash
Response: Not available
Cab Id: 0

Problem signature:
P1: Microsoft.FlightSimulator_1.29.30.0_x64__8wekyb3d8bbwe
P2: praid:App
P4: 00000000
P5: FlightSimulator.exe
P7: 00000000
P8: c0000005
P9: 0000000001543e15

Attached files:

These files may be available here:

Analysis symbol: 
Rechecking for solution: 0
Report Id: a37f346f-db24-48af-8a22-9d1235807723
Report Status: 268435456
Hashed bucket: 2c1eac22ed88c8f4e394deb474b453c9
Cab Guid: 0

2 posts were split to a new topic: Ingame panel not loading