Cannot update FMS Data Manager with latest Airac Cycle (2203)

Last Airac issue was a problem…this time (and I have no idea what I did) the only Add-on to load correctly was the XP11.5.
I have deleted and reloaded a couple of times, but when I try to update, …it starts…gets to the ‘chunk’ buffer (set at 1.5Mb ), which is about 6% of the download in question and stops.
If I try to exit the Data Manager, I get a warning box saying 'Download in progress etc (which it clearly isn’t because if left, nothing has happened after an hour or so ??).
Why can’t I uplaod this latest Airac…“Data out of date” is very frustrating!!
Thanks,

Hi…,

Welcome.

I suggest a fresh start using exact procedure below :

Please disable any Antivirus and firewall. Uninstall AV if needed.

In FMS Data Manager Settings Unregister Account:

Use Windows to uninstall FMS Data Manager. Specifically:

  1. Press Start and open Apps & Features.
  2. On the right hand side, open Programs and Features.
  3. Find Navigraph FMS Data Manager in the list, select it, and press the Uninstall button above.

If they exist, delete folders:
c:\ProgramData\Navigraph and c:\Program Files (x86)\Navigraph.

Download and install latest FMS Data Manager to the default location.

Please let us know how you get on. If still an issue, please post screenshots of errors using Guide to posting Screenshots

Cheers
Ian

HI Ian, I have faithfully followed you suggestions, but unfortunately without success.
I have posted a copy of the screenshot showing what happens when I try to update Airac cycle.

What is really confusing is the fact that for some unknown reason (which you can see), the XP11 add-ons were updated?

Many thanks.

In Addon Mappings tab, please select and Remove all entries. Press Save, Scan and Save
Post screenshot.

In Addon List select X-Plane 11(11.50+) and Update. Is this updated correctly
Same for X-Plane GNS430… Is this updated correctly. If not post screenshot.

Please post screenshot of Settings tab showing paths for FS’s.

Please upload latest log from c:\ProgramData\Navigraph\FMSClient\logs

Cheers
Ian

1 Like

Hi Ian,

Appear to be going round in circles.

I am unfortunately of an age before the teaching of IT and associated computer skills, so my knowledge is therefore severely limited.

The issue appears to relate to the fact that, although the update (for which ever add-on is selected) starts to update, it stops as soon as it has reached the ‘chunk’ setting in settings.

I have no idea why the XP11 (11.5) update worked…but as can be seen from the current screen shot it is up to date. However, when I tried to re-update just now as you asked in mail below…it got to the ‘chunk’ size and stopped.

FMS log 13 Apr 2022.txt (36.4 KB)

Your log shows email and password errors. In Settings try unregistering account , then logging in with the details of your account which has the subscription.

Any joy?

Ian

Hi Ian,

The errors at log in were mine as I made a mistake when typing…I subsequently gained access without issue.

I am still not getting past the stage where it ‘freezes’. I still think it has something to do with the settings menu…specifically ‘data chunks’

Would this have something to do with my fire wall? If so, why is it only now becoming a problem?

However, I have re-set my password once again and will go through the steps already tried once more.

I am not sure that ‘deleting’ the Data Manager actually removes all the files, as it now (having been removed and replaced on at least 6-7 occasions), reloads almost instantaneously.

This doesn’t get us past where we started some time ago.

Can you please tell me how I can (safely) completely remove all the Data Manager software, to a point where I can re-load and perhaps start from scratch.

Alternatively, can you tell me how to manually update the data base, as there appears to be that option available.

Many thanks,

David Browning

I have been looking at my ‘log’ for FMS…could you please tell me what this line means in the latest attempt to download the updates??

[2022-04-13 11:02:11][6][1] - CInitializer::onUserInitializeFailed [D:\Development\Repositories\Navigraph\fmsdata-manager\NGFMSClient\cinitializer.cpp:115]: {

“error”: “Access token was not found.”

}

Many thanks,

David Browning.

Btw, we have an excellent technical panel on our discord site, I’m sure you won’t mind if I post the log there, to see if any of the in house developers can spot any issues .

Than send it via PM please … thank you

Cheers,
Richard

Hi,

I wasn’t actually referring to the Navigraph Discord as I logged in, and out almost as quickly, as I noticed that pleas for technical help were directed to the forum…which is where I have initially sent my query.
But I don’t seem to be getting very far.

The discord site was entirely different, but has a room specifically for devs and tech issues with the various software programmes currently in use.

I might mention that one particular Dutch developer was at pains to point out that even now, updating software is always giving problems in a whole variety of programmes.

It is a shame I don’t seem to be able to wipe the board clean and start again…particularly as I have just paid another full years subs to you Guys ?

Best rgrds,

David Browning

David,I don’t speak from Discord - I speak from a PM here in the forum when you click on our names …

It´s like, when I click on your name:

Cheers
Richard

Thanks Richard.
To be honest I what I would really like is a solution to my problem.
Thank you.

Kind regards,
David B.

Understood, we too … we will look into the logs as soon as we have it. Possible we will see something, but we will find a solution, thats for sure. Thank you!

Cheers,
Richard

Hi Richard.
I hope that Ian has received a copy of the logs, if not kindly let me know and I will post them once more.

Kind regards,
David Browning.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Hi Ian,
Still not able to update the Airac for March 2002 and now the update for April/May is released.
My previous question/mail didn’t get very far…and ended with an open remark from Sam? and after 4 days the thread was closed…so basically I am no further forward. ??
I sent you personally a copy of my ‘log’ file, which you commented on as having log-in issues ?
So where does this leave me ??

I really would like to get this issue resloved, Navigraph/Simbrief are fantastic products, and not having them working properly is like hving your arm chopped off .

Many thanks,
DB

Hi David,

There is some confusion over which logs. Please upload logs again.

Cheers
Ian

Hi David,
try following please:

  1. close your sim´s
  2. close the FMS Data Manager
  3. go into the folder %ProgramData%\Navigraph\FMSClient
  4. delete the settings.conf file
  5. start the FMS Data Manager
  6. login, let the app re-scan your system
  7. try to update it again

Cheers,
Richard

Hi Ian,

Many thanks for your reply.

I have also had a reply from Richard who asked me to delete the ‘settings config’ in the Program Data file, reload mappings and try to update, which I have done, unfortunately without success.

I have attached a copy of the ‘log’ for this attempt, so you can see exactly what did (or did not ) happen, as it is meant to.

The log says that ‘*Access key not found’…*is that significant, I have really no idea what I am looking at tbh.

The only other thing I have done is to alter the ‘chunk size’ in settings to 0.5Mb.

When I try to update, the program shows 0.5 MB /25.99 MB 1% and that is as far as the download gets (I have tried leaving it for at least 10 minutes).

I have attached screen shot of download screen after pressing ‘update’.

But when I try to come out of the download, a box appears saying that there is a download in progress. I have attached a screen shot of that as well.

Hopefully we can sort this out between us.

Many thanks.

David Browning

20220425-093956.log (22.6 KB)