AIRAC 2206 - FENIX A320 - Installation fails

Since today, with AIRAC 2206, the installation of the NavData for the Fenix A320 fails. The Navdata Center shows for a brief time that it hast been installed but switches then back to “install” state.
Also, a manual download fails with an “Access denied” message in the browser.

same for me, now trying to reinstall Navdata Center

Can´t reproduce it guys sorry …

I have updated Fenix via the Navigraph Navdata Center without any issue … please reboot, relogin and try it again. No issue seen on our end …


Tried that already. Does not help.

The screenshot shows what happens when i try to download the manual install package from your website.

Hi guys.
I’ve got the same issue. Unfortunately nothing helped to workaround this.

After removing Navdata Center and traces of it in %appdata% and then reinstalling it, I could install Navdata for MSFS and other addons, except for Fenix, it showed “update”. So I did, but without any effect:

Manual Download doesn’t work for me either.

Same issue for me. Reinstalling Navdata Center doesn’t change anything for me either.

Seems to work for me now.


I can confirm it works now

1 Like

Installation via Navdata Center works.
Manual download still fails.

Please use the Navigraph Navdata Center only. We will rwmove the manual installer in the next cycle.

Thanks to all for the feedback


Seems like Fenix has disappeared from the FMS Data Manager. Can’t get to update my cycle. Using the nav data centre doesn’t work.

Never mind team problem solved I had to go to express installation to update it

I can only see PMDG on the list, Fenix has gone

How do i do that? express install on what at?

Express installation in Nav Data Central. Hit the 2nd tab you’ll see it

My download of navdata was fine, but will not allow me to login. I get error message “ACCESS DENIED. This application requires an active Navigraph Subscription.” I verified I have an active ultimate subscription from 2021-2023. Can someone PM me to assist with navdata center login for MSFS?

and you login with your account jsollender, right?

I get no option on how to login. It goes in the background without me entering username vs email.

whether email or username login, I do get an MS Edge page with address to redirect, but the page does not redirect and open.