After NaviGraph update -> "Choose an application to open the Navigraph Charts" -> will not open in Firefox

I updated the NaviGraph app after receiving a message indicating an update was available; that was yesterday. Since then I have not been able to start NaviGraph with Firefox as my preferred browser; it asks me to “Choose an application to open the Navigraph Charts.” I have had no issues in the past two years with my Ultimate subscription until this update. I pointed it to the Firefox executable when it asked to choose an application and after that, it opens a browser tab but, does not display any content (hangs?).

I have searched the forums and tried a couple of the solutions that were attached to the same reported issue by others including (1) de-installing NaviGraph+SimLink and reinstalling (2) a solution from 2021 in which very specific folders were deleted. I have also cleared my browser cache of all data, disabled all my browser extensions that block adds, popups, and perform anti-tracking but, with no luck.

I do not want to install Google Chrome or any other browser for security/tracking reasons. That is not an option nor should it be a solution.

Any guidance/assistance would be appreciated. Thank you, in advance.



For Simlink start up settings in Firefox, please see FAQ - Firefox may start an app when Simlink Starts.

Please let us know how you get on.


Hi Ian,

Thank for your prompt response. So, while I was waiting for a response I went through the process of uninstalling everything again and then reinstalling.

(1) Simlink - after reinstalling and running Simlink I was notified that there was an update so I downloaded that and installed it. After I launched it I got the browser popup about allowing the link to always be opened which I checked off and Simlink ran allowing me to sign-in. After the fact, as per the FAQ you linked me to, I did verify that the application settings for Simlink in the Firefox settings were correct.

(2) NaviGraph Charts - my issues with this persisted until I received the link to the FAQ. Although not listed in the FAQ, NaviGraph Chart also has the same app setting in Firefox but, the setting for that was set to “Always Ask.” I changed it to “Use Navigraph Charts (default)” similar to the Simlink setting, and that worked; I was able to sign-in to NaviGraph Charts.

Thank you so much for your consideration and time- obviously the Firefox app settings needed to be changed and that was the source of my issues. Very much appreciated!



You are welcome. Glad is is resolved.

Happy flying.