[Working now]Can not Create Flight

No drop down when enter a ICAO same with Destination
Win 10

think it s a server problem i am having a simialr issue with creating flight plans (but it has to do i cannot create it after entering values)

I Suspect that too it worked yesterday

Unable to use the app right now, web app too.

The Simbrief integration doesn’t work either.

Same here. Keeps telling me it is loading flights…Not able to do anything

Same probleme here! Loading flightplans from Simbrief.com broken.

I’m thinking it is a server issue as well. I have tried to create a flight plan and have one of a few things happen today:

  1. Can’t start to create a flight - initial screen does not load ICAO airport names as usual just like original poster screenshot.
  2. If I can enter 2 airports, it only gives direct routing even though Auto Generate My Route is checked using high airways
  3. Get an error message that says route is not possible (with autoroute generating)
  4. Destination airports have no arrivals or approaches available even though major international airports - example Los Angeles, CA

Working now again just tested

1 Like

Hi Team,

Sorry for inconvenience. This has been resolved as per Can't Access iOS on iPad - #9 by stephen.

Would appreciate your confirmation.


Thank you for your help. Confirmed working again. I’m really enjoying using Navigraph and SimBrief.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.