Navigraph charts unable to load flight plan

Hi, I am having an issue where by navigraph is unable to load up the page where I can choose what flights I want. I have tried using different devices all have given me the same result.

1 Like

Me too. Cannot load anything on desktop or laptop.

Same problem … cannot load something

Yes. Can confirm… this morning I launched the Chart App and unload my previous flight plan.

But after that, no button to import or create flight plan

Same here:

Same problem here this morning, was working fine last night.

I have the same Problem.

same issue i can connect to web page but no charts/flightplans load

Same here. I thought it was my problem, I have even reinstalled the application.

Me too
Is it possible to install an earlier version?

Having the same issues on android tablet and desktop versions.

Now it will slowly load flights but wont allow import.

I’m also having this issue.

I was wondering the same…

Hi guys, we are trying to collect the discussion about this problem here: Technical Difficulties Reported

Same here. Yesterday all was fine. this morning although I have a valid flight plan in Simbrief once the charts app is open it takes a long time to display the plans in Simbrief and once I finally select one its blank. No option for departure or arrival selection of SID, Stars etc

Same issue here not able to load flight plan on desktop and tablet.

I have the same issue. Was working a couple of days ago but not tonight

I too am having this same issue, with the same screen situation as the image 3 posts up.

I see this has been moved to another thread, and it is being investigated.

Won’t import from Simbrief either