Simlink shows wrong position - XP11 & Apple Silicon

I just updated Navigraph charts and the accompanying Simlink plugin to version 8.29. The app worked fine until I was in flight and tried to see my location. At that point the app switched to my browser and reported an unknown error. This repeated and I now cannot load my route at all. Something amiss here, Ian. Thanks.

Steve Haines

1 Like


I have enabled some additional logging on your account. Please try again now and then report back when done.



Stephen, thank you for the quick reply. I downloaded and reinstalled the Charts app and Simlink plugin. I then reloaded XPlane and now my flightplan appears on the map. However the airplane is located off the east coast of Africa while it should be in Minneapolis. So this suggests some sort of error is going on with the updated Simlink plugin. If you like I can trash both the installed plugin and the downloaded DMG file and then do a new download/install to see if that clears up the problem. And, of course, I can always try the standard fix… reboot the Mac. Please advise…
S Haines

Confirmed I also initially had the location completely wrong, however 30 mins later Navigraph Charts now just says:

Something didn’t work out as expected.
If the issues does not resolve themselves, please visit our forum for support.

I’ve tried deleting both Navigraph Charts and Navigraph folders in Library/Application Support (mac)

I have also uploaded the latest Simlink and Navigraph charts on Mac and experiencing the same issues as shaines.

@RCTOFliesPlanes and @Bladerunner , are you both also using X-Plane?

yes I am using X plane 11

Specs for me:

MacOS 13.4.1 (c)
Xplane - 12.06r1 - via Steam.

Apple M2 Max - running xplane with Rosetta.

And you are also on macOS @Bladerunner ? Sorry, forgot to ask.

Mac OS Catalina 10.15.7 with latest X Plane 11 version

Thanks! We will investigate this ASAP. I can not reproduce it using X-Plane 11 on Windows at least. It’s past midnight here and we will begin the investigation on macOS tomorrow!

Thank you for all the additional information!

Kind Regards,

No probs, yeah def time to rest if it’s gone midnight!

Info for the morning, is I’ve rebooted xplane and charts and it’s loading up, but the offset is still there.

Here’s some shots of where another app says I am (which is correct); and what Navigraph is saying:

Other App (correct)

Navigraph (wong)

I am using XP12 beta v0.6r1 on a Mac Studio M1 with OS Ventura 13.5.1


Thanks for the additional report @shaines ! I cannot reproduce the issue on X-Plane 12 running with macOS Sonoma, but I can reproduce the issue in X-Plane 11.

We are investigating!

Same Issue for me, Navigraph has placed me of the west coast of Africa and not at my location (EGSS) Im using Mac OS Ventura 13.5.1

I also updated Navigraph charts and the accompanying Simlink plugin to version 8.29. The app worked fine until I was in flight and tried to see my location. Navigraph now cannot load my route either.

Can confirm that Navigraph Charts crashes when linked with Simlink in IOS setup with the 9/5 updates. Using xPlane11 on iMac M1, 16GB Ventura, 13.5.1 and Navigraph Charts on iPad (both worked flawlessly before the updates). Both Simlink and Charts updated at the same time so it was tough to see what was the cause. But simlink did not crash. Charts crashed repeately and did show me in the middle of the Indian Ocean while flying in the EU. I did find a workaround to at least use maps and charts. I disabled Simlink, in Charts, disabled Sync with flight and did not hit the “link icon” (flashing triangle icon on the top). It did not provide situational awareness but I did gave full function of all the charts and weather. Hope this helps.

We have been able to reproduce the issue with Apple Silicon and X-Plane 11. We believe to have found the culprit, and will issue a fix as soon as possible! As mentioned, we have also not been able to reproduce this issue for X-Plane 12 so far.

Please note that we have not been able to reproduce any kind of crashes related to this. If you are still seeing crashes, please post more details in a separate topic!

I will let you know when an updated Simlink version is available for download!

Kind Regards,

Same issue here, departing out of Tokyo, Simlink first placed placed me in eastern Africa. When airborne, I’m at the north pole (with some insane simulator coordinates reported in the plugin: CleanShot 2023-09-06 at 22.02.36) and when opening, I get an error: CleanShot 2023-09-06 at 22.02.26

Running X-Plane 12, 12.06r2 on an M1 Max Macbook Pro running macOS Ventura 13.5.1.

I’m also seeing this issue. Departing out of Orlando, Simlink showed me in central Africa. After flying northeast, it started giving me the “INOP Something didn’t work out as expected” error and I was unable to view charts. I checked the javascript console on and the INOP situation was caused by a lat/long out of range error. The displayed lat/long values in Simlink were indeed nonsensical. I don’t want to start Simlink right now and get back to the INOP condition, but it was something like 979231,-20.

This is with X-Plane 11.55r2 on an M1 Max MBP.

I also started at the east side of Afrika, going at almost light speed over the earth. X-Plane 12.06 on a Macbook M1 Pro.