Simlink not connecting with MS2020

Hi guys, I am having an issue with Simlink. It dosnt connect with MS2020. Its running before i start up the sim but the issue continues. Tried uninstalling multiple times but nothing.


Please check this Solution to fix the MSFS connexion with Simlink.


Vishal Ahir

1 Like


Already tried this and the issue continues.

Kind Regards,

Same here. Very difficult to connect Simlink after the last update. I never had this kind of trouble but now I can’t connect.
One second after loging you receive a message “You have been logout”
Need a solution

since last update (downloaded on monday and installed it today)

Solution helped me!

Somebody can tell me or maybe better make a snapshot with details to fill up the settings ?


Please check this .

After cleanup please reinstall the Simlink Plugins.


Vishal Ahir

Thank you for your reply. I followed your instructions but I can’t connect.
Here is what I have

Hi There, running

Having the issue “Navigraph Simlink cannot detect a flight in your simulator. Not broadcasting flight data to server.”

I carried out the check in the environment variables, and added the entries to paths; no improvement.

Deleted everything to do with navigraph in appdata/Roaming and it fixed it for me when re-installed.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.