Simlink - MSFS2020 client connection failed, simulator is not started

I have been trying to setup Navigraph charts on my new system after fresh windows 11 home install and fresh MSFS2020 install. In the Simlink status page I get the following


The Simlink log is as follows

simlink_2023-04-25.dlog (15.6 KB)

It appears the simulator is detected but the connection cannot open and it believes the simulator is not started when it is in fact in a flight. I have tried with windows firewall disabled and it is the same. I have also tried uninstalling and reinstalling simlink and navigraph as per other previous posts, added exceptions for navigraph and simlink in the firewall, no proxy is enabled in networking.

I never had any issues with navigraph and simlink on my previous computer with MSFS2020 which was originally windows 10 but upgraded to 11 for past 3 years.



Please try steps at SImLink disconnecting during flight - #6 by vishalahir


Hi Ian

I did already try that and did extensive searching through the forum prior to posting. What I am trying now is a complete fresh MSFS install on a freshly formatted hard drive. Perhaps there was a few lingering files on the drive despite my previous fresh install of MSFS. The install location is custom (not on C Drive) but my old setup was also this. Quite bizarre

I will let you know if that is the solution.



Ok following a fresh format hard-disk install it is now working! One file I did notice had an earlier date modified and was not deleted in my previous ‘clean’ install attempt was a file called .GamingRoot which was a hangover from my old computer install and is not deleted automatically when uninstalling the sim.

It is possible that simlink was waiting for a connection to MSFS using a hangover file from my original install on my previous computer. Either way the problem was MSFS install related.

Thanks for your help