Simlink cannot connect to FSX

Hello everyone,

I’ve just subscribed the Ultimate subscription of Navigraph and installed Charts and Simlink. Currently I’m having a problem of Simlink not connecting to the simulator, which is my FSX. I read the other posts for solutions like re-install Simlink and Charts then restart the computer but it still not working.
I’m running the latest version of Charts and Simlink which are versions v7.7.1 for Charts and v1.1.25.0120 for Simlink.

Here is my log file and the screenshots about this:
simlink_2022-04-01.dlog (71.3 KB)

Screenshot 2022-04-01 122704
Simlink general tab
Screenshot 2022-04-01 122638
Plugin status tab

Plugin settings

Please help me!



You talk of FSX but your dlog only refers to MSFS. Which is it?
Make sure you have the Flight Sim (FSX or MSFS) actually running when you run Charts and Simlink.


Hi Ian,

I really had my FSX running, but the dlogs are still just refer to MSFS instead of FSX. And I also run FP on Charts and the sim, but the moving maps are still not working.

3 posts were split to a new topic: Simlink For FSX (and FSX SE)