Simlink 1_1_34_2901 issue - update can not be run

Can someone look into the installer code for Simlink please?

The issue is the latest Simlink does not automatically close the Simlink app/task from running in the background when the update is run. I have tried both with and without Admin rights and the update does not close the app meaning the update of the new version is stalled. I use the same procedure each time and it has always worked but not this time.

As a workaround and suggested by another forum topic, you can enter Task Manager and close the Simlink task manually and then run the updater. This works.

However there is something definitely wrong with how Simlink is managing the close out of the running app prior to installation of the new version. Could someone from Navigraph look into this please?

Thanks.

Hi,

I cannot reproduce. I am prompted to quit Simlink in the Simlink install process.

Could you try running the latest installer again now (while the latest version of Simlink is running)?

Regards,

Stephen

Hi Stephen,

The installer works now with _2901 already installed and running.
The issue I saw was with the previous version and then running the _2901 installer would not close the app. Simlink was running because in Task Manager I had to close it down manually.

Do you want me to try and reproduce the issue with the previous version?

Regards
Mark

Mark,

Just keep an eye out the next time Simlink wants to update, and if you see the issue again then post here.

Regards,

Stephen

OK. I will report back if I see the issue again.

Cheers.
Mark

Hi,

Which simulator/version are your running by the way?

Stephen

Hi Stephen,

I am running P3Dv5.3 HF2 on a Windows 11 Pro system (22H2).

I also left an email for Vishal since he wanted to take a closer look at my system. Maybe today?

Cheers
Mark

Vishal found the issue on the previous version of Simlink where the app would not close down to install the newer version.

2 Navigraph files had to be allowed through Windows Defender firewall. He will post more details on what the solution is.

Hello,

Please ensure that Simlink application is allowed through your system’s Firewall or antivirus, especially if you have installed an Antivirus software.

Although the Simlink installer automatically adds the Simlink application to the Firewall list, it may get removed from the list due to system updates or Firewall-related settings changes.

Therefore, kindly verify that the Simlink application is present in the Firewall’s allowed application list, as shown in the reference image below:

Please do let us know if you encounter any issues with the Navigraph Product.

Best Regards,

Vishal Ahir
Navigraph