Simlink Won't Close to update

Good morning. There is an update for simlink but when I try to install the update simlink won’t close. I tried installing keeping it open but there is a file that not removed as it says access denied. Is there another way to close simlink? Right clicking on the icon doesn’t give me that option and I don’t see it in the task manager.

Running windows 11 64 bit pro.


Same happened to me this morning and I erased EVERY files from navigraph and re install them all and now I was able to update simlink.



If you have a flight simulator running, please make sure to close it before attempting to update. If the update still fails, please restart your system and try again.

Also, please ensure that the Simlink Installer is run with administrative privileges.

If you encounter any issues with Navigraph products, please don’t hesitate to contact us for assistance.

Best regards,

Vishal Ahir

Not working on my system either. Will not update and will not close SIMLINK. How do I close SIMLINK??? And I am not running flight sim and I have started my system twice and I am using admin privileges.

Hello, I have exactly the same problem, I cannot install the latest Simlink update, every time I try it does not allow me to do so because it says that I have the program open (I have my flight simulator closed) then when I try to delete the Simlink folders it doesn’t either allows me to do it the following message appears “The action cannot be completed because another program opened the folder or one of its files” (?)

Thanks for those sharing their issues. I ended up uninstalling sim link through program manager. There were still some files that didn’t erased but I restarted my computer, re downloaded Simlink and it fully installed. It is now working again.

just open the Task Manager on your pc and click on Details then search for NAVIGRAPHSIMLINK, select it and click on End Task.
that worked for me


Please check this also.

KInd Regards,

Vishal Ahir

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.