Simbrief and Navdata cause X-plane 12 to lock up

I have had X-Plane 12 beta since it was released. I use Mobflight (plugin) to connect my two G1000 glass panels to the sim. I added Navigraph a month later and I love the product (also used in MSFS 2020). However, I have noticed that X-plane 12 has been locking up about 95% of the time. It happens anywhere between 5 minutes into a flight to over 45 minutes into a flight. It gets worse (locks up sooner) if I restart X-plane without restarting the PC. At first, I thought it was just a bug with the beta but then I started tuning off all the plugins (only three) and found then when I turn off the simlink/navigraph plugin, X-plane does not lock up. I make sure the navdata is updated and then I make sure it is not running in the background as well as simlink. I did get one short flight with simlink working but the very next flight X-Plane locked up about 10 minutes into the flight. I’m I doing something wrong? Do I need to do things in a certain order for this to not happen?



My experience is that the navigational data itself is rarely the cause of lock ups. It may be that our more comprehensive data exercises more of the aircraft systems, which might show up bugs.

I would try disconnecting the Mobiflight plug in, to see if that might be causing an issue.
Also try disconnecting your antivirus in case that might be affecting things.


Thanks Ian, I will try unloading the mobiflight plug tonight when I get home from work. There is no antivirus since this is a dedicated Flight sim computer. Only direct updates for X-plane, MSFS 2020 and Navigraph are gathered from internet. Everything else gets downloaded from another computer with antivirus.

Okay so that night I got home and tried a flight with only the Navigpahe simlink plugin, crash to desktop within 5 minutes but I do not think simlink was the cause of the crash. Then without restarting the PC I loaded X-plane 12 back up with only the mobiflight plugin, did a 45-minute flight landed with no issues. Did another flight wit only Simlinhk plugin and worked okay for 23 minutes and then locked up. Restarted X-plane 12 again loaded only symlink and did an 1.3-hour flight and no issue. So kinda weird. Since the issue seems to be inconsistent, I decided that I needed a clean OS install since I was kinda having other types of issues with MSFS 202 as well. So working on that now and Already MSFS 202 is working.acting much better net will be X-plane 12, I will test that and then slowly work on addons testing before adding the next one. Hopefully, everything will work in a harmonious environment and all the addons play well in the sandbox together.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.