Sign In seems to still fail

I’ve read all of the similar threads on this with the most recent over 2 weeks ago. When I get to the Sign In splash screen, I’m getting the same error as described by the other threads (“Sign in should progress in your default browser…”) which then times out after nothing happening. I downloaded and installed (and then removed and re-installed) Charts in Windows 10 today so it should be the updated version (as described in prior threads on this). Also, my default browser is MS Edge, which I would really prefer not to change simply to get this one program to work.

As I’ve just purchased my subscription today, it’s really frustrating that I am unable to use it.

Sorry to hear you are having issues. We don’t see this recently happening to others so it isn’t currently a known or common issue.

Would you mind temporarily switching default browsers just for the actual sign-in? Does it make a difference? After you have completed the sign in you should be staying signed in, so you can safely switch back to Edge.



Hi Stephen,

Thanks for your response. I tried this (changing to Chrome), but still same outcome (click “Sign In” button; get the “Sign in should progress…” message above along with a “keep out” (or null or circle-with-slash) symbol replacing the mouse arrow; then times out to the “Sign In” button again).

Any other ideas?


I should add that when I try starting Navigraph Simlink, it signed in perfectly fine…with MS Edge. Is there another way to “sign in” to Charts?


One other note, if it helps for diagnosing:

I also attempted to click on the “Navigraph” and “Navigraph Charts” links at the bottom of the splash screen and it brings me to the website (unsure of the browser driving this connection). When I try to go to my account screen, this window blanks out and never loads. Since there is no “back” options, I try to “reload” “forced reload” and every other option. Mashing buttons I eventually got to a 403 Server Error page and then only could exit out of this window, which also closed the splash screen.


We’ve brought this up internally but we are puzzled. We had an issue with your symptoms but it was resoved before Christmas and we haven’t seen any reports like yours since. We are not able to reproduce. Maybe there is some security setting, antivirus software or firewall that is interfering with the login, but that is difficult to debug. Maybe you could temporarily disable and see if it helps.

Other than that - do you have a second computer, just to test there?

The only workaround I see currently is to use Charts Cloud, the web app (, which has almost identical UI and functionality as the desktop app, it’s the same underlying app. Would that work for you?



Same for me. Doesn’t matter whether I try with Edge or Firefox. Tried restarting the computer, and cleaning the cookies. Nothing helped. The Charts application just goes back to its “Sign in” screen from after the browser login.

So fyi, I got it fixed by reinstalling under a different path (“Navigraph Charts” instead of “navigraph-charts”), and as admin user.