Navigraph App Throwing JavaScript Erorr

Hi, I just subscribed to Navigraph and installed the Charts app. This does not allow me to login due to a javascript error:
image

I’ve tried the troubleshooting steps I could find, my system is up to date, default browser workes fine (login with SimLink had no issues).

Hi…,

Welcome.

We shall investigate. In the meantime you can use Charts Cloud. It has the same functionality.

Cheers
Ian

Hello Ciprian!

We’re looking into the issue, but we need more details.
At what point in the sign-in process does this error occur?

Kind Regards,
Malte

Hello Malte,

This happens ~20 seconds or so after pressing on Sign in button. The application takes this time and then throws the error attached.

Tried changing the default browser to Edge and Chrome, restart, reinstall the app, still the same.

Hope this helps!

Thank you for the details!

Unfortunately, we are still at a loss as to what might be the cause of this. In order to gather some additional details, please follow these steps:

  1. Press ⊞ Win + R to open the run prompt
  2. Type %appdata%\navigraph_charts\logs and press enter
  3. Find the log file and attach it to your answer to this post

Thank you for your patience, we’re doing our best to find the issue!

Kind Regards,
Malte

Please find attached the requested file:
main.log (2.4 KB)

Thank you for the log! Unfortunately, that still does not narrow it down. Could you try running Charts on another network, preferably by sharing your phone’s internet with your computer? That way, we could rule out any firewalls/router security rules etc.

Hi, tried this, it does not work.
I strongly do not believe this to be a firewall/ port forwarding or any other network type of error as the simlink worked as expected.

Could you kindly provide an update on this and on the navdata center issue as I am not able to use the ingame addon cause of this and is frustrating to pay a subscription, have issues and not be able to troubleshoot it properly.

If this is not fixed soon ai will ask for a refund on the subscription.

CAN I GET A MORE TECHNICAL PERSON TO HAVE A LOOK AT THIS? SKYSAIL HERE LOOKS LIKE HE HAS LESS KNOWLEDGE ABOUT HOW TO DO APPLICATION SUPPORT FOR NAVIGRAPH SOFTWARE THAN ME, AND I AM THE END USER THIS TIME.

LET ME REPHRASE THIS, ALL APPS IN MY PC INCLUDING YOUR FMS DATA APP AND YOUR SIMLINK APP WORK AS EXPECTED, SO IT’S VISIBLE FROM THE MOON LIKE THE GREAT WALL OF CHINA THAT THIS IS NOT DUE TO NETWORK OR FIREWALL OR ALINENS.
LET ME EXPLAIN IN EASY TERMS HOW TO DIFFERENTIATE:

A. YOU PRESS LOGIN AND APP THROWS JAVASCRIPT ERROR WITHOUT LUNCHING BROWSER = NOT A NETWORK ISSUE
B. YOU PRESS LOGIN, APP LUNCHES BROWSER BUT SITE IS NOT REACHABLE = MAYBE NETWORK ISSUE.

HOW DO YOU RULE OUT ANY FIREWALL ISSUES IF i SHARE MY PHONE INTERNET EXACTLY SINCE THE FIREWALL IS INSTALLED ON MY LAPTOP NOT ON THE WIFI NETWORK. SOME ROUTERS DO HAVE FIREWALLS, BUT THE FACT THAT I CAN USE 2 OF YOUR APPS PROVES THAT THERE IS NO ISSUES WITH THE FIREWALL SETTINGS AS I AM ABLE TO CONNECT TO YOUR SERVERS.

CAN YOU INSERT A COIN AND TRY AGAIN, AND BEFORE PROVIDING ME WITH A DIFFERENT TROUBLESHOOTING STEP LIKE GIVING A BATH TO MY LAPTOP, PUTING JET A1 FUEL IN IT FOR A BOOST OR DANCING WITH IT TO IMPROVE IT’S MOOD TRY TO GIVE IT A SERIOUS TOUGHT.
:wink:

I was kind enough to try a few times the steps recommended, even if they had no logic as you can see from their lack of results, but enough is enough guys, time to get serios and stop playing around as your lack of professionalism and technical knowledge is costing me subscription time

Charts Cloud should work on your machine.

Please drop the sarcasm and personal attacks.
If you don’t wish to work with us to resolve issues on your machine, no problems we shall refund.

Ian

Takes a bit of nerves to tell me I don’t want to work with you on this while I waited one week and got 0 proper help on the issue.
what i said above is not a personal attack, as I have no relationship with the person. it’s barely a feedback based on the knowledge and performance while investiigating this issue. I am not a stranger to product support myself but I never had a case on which one of my users told me that what I am recommending has no logic, giving enough reasons for that and me getting mad at him for being less technical than him :-1:
Please investingate the issues accordingly. the steps provided by the dev here did not work at all and I do not see any additional ones. explain to me exaclty how do I not want to work with you on this one?!

btw. took some screenshots of these funny conversations, will share them accordingly so people will have an idea what support to expect from navigraph.

How do I install the in app addon without the navdata center?

You just open https://charts.navigraph.com in a browser.

self facepalm :roll_eyes: :man_facepalming: :man_facepalming: :man_facepalming: I don’t think you understand what I’ve asked. In the benefits of my subscription I am told i can use an addon in MSFS for charts. How exactly do I get that?

As part of your subscription you can use the numerous forms of Charts. At the moment Charts In Game Panel isn’t working for you, so I have suggested an alternative as a workaround.

The alternative is not very useful as I have just a laptop screen not dual screen configuration, so I need to alt tab or use it on my phone, which is kind of small even if it has a 7 inch screen. How long does it take to fix this isse so that I can fully use my subscription as it has already been 7 days (23% of it’s duration). Not a very good start for a trial where I was supposed to decide if to buy the annual package or not if I may add. (not personal attack flag, just feedback.)
Do I get an extension for the time it took to troubleshoot the error and maybe some suggestion of steps that would actually work?

I don’t know how long it will take to resolve your issue. The developers will work on it during the working week. We want you to be satisfied, so I am sure we shall work something out, or a refund if we cant.

yes, but as all technical support team you should have a service level agreement for issues, so that you can massure the success rate of the service. This is sort of the most important KPI when it comes to tech support or application support.
The issue is opened since the 9th of October, so 5 full business days passed (Mon to Fri). More it seems like we are very far from this being resolved.
I’ve asked in the other thread if it’s useful for you guys if I setup a vm and try to use the app there, but I would appreciate it if before that you would do some QA test on it just so I won’t lose my time to find out that it does not work there as well. that should sort all possible glitches between msfs and the apps or any other compatiblity issues. My 10 years of experience in technical support and development makes me think the issue is not workstation related, as that would mean other apps should not work as well, instead is just these 2 and the fact that they have been reinstalled multiple times on different drive location rules out any corrupted files, as long as the package available for download is supposed to work.

If you want me to be satisfied, then kindly have an app sr dev or architect review the issue, as the steps that I have been told until now had no result and no logic for me personally, which is not helping in de-escalating the situation.

This post was written after an internal discussion with all involved developers.

The Navdata Center app and the Charts Desktop app share technical platform being Electron apps while FMS Data Manager and Simlink are c++/Qt. We have thousands of users running either app, without this issue (no other forum reports) so it is not a general issue with our apps or APIs.

During the internal discussion we concluded that the most likely cause of the error message you posted initially would be a networking/connectivity on your machine affecting the Electron stack specifically, possibly some latency issue that causes this error specifically in Electron on your machine. We cannot reproduce it on our end, but it was the best idea we had. This reply by Skysail was written 3 days ago. Now you replied 13 hours ago questioning the technical expertise in even asking this question, and then immediately with follow up posts that are very heated questioning our team members and expertise.

It is unfortunate that we were not able to resolve your issue immediately but for issues that only affect one individual and which we are not immediately able to reproduce it can take both days and weeks. There is no point continuing this as you clearly have made up your mind about our troubleshooting, and this is a forum of respect. We have refunded your subscription in full and will now lock this thread.

Regards,

Stephen