Root FSX folder opens on game startup


I recently installed and then uninstalled Navigraph simlink as I only have the airac subscription, so didn’t need simlink. However, now every time I start FSX, the root FSX folder opens in windows explorer. I read online that a faulty XML file can cause this. If that is the problem, how do I dig this XML out? Or is it something else altogether?



Hello Matthew! Welcome to the forum

It does indeed sound like the Simlink plugin for FSX has not been removed correctly or at all. The easiest way to go about this is to follow the below steps:

  1. Download and install Simlink
  2. Open Simlink, select the Plugin tab and uninstall the FSX plugin.
  3. Close Simlink, uninstall it using the “Add or remove programs” tool in Windows
  4. Make sure that the folders C:\Users\<username>\AppData\Roaming\Navigraph\Simlink and C:\Program Files\Navigraph\Simlink do not exist. If they do, delete them manually.

Please tell me if you have any questions!



I’ve walked through the process but it has not solved the problem. The game still opens the FSX root folder when I start the game. I’m not sure what else to try or even where to start? FYI - I’m running FSX Acceleration (disk version) on Windows 10 with 8 Gb RAM and Nvidia GeForce GTX 950M. A Medion P6661 to be precise:

FSX is installed on the SSD but I installed and uninstalled Simlink on the HD.

Found the problem. The problem is the Simlink doesn’t remove the entry in the dll.xml after install:!AtBLDmeWaSESjecJKmie9BU14gudbw

Go and find the dll.xml in C:\Users[user]\AppData\Roaming\Microsoft\FSX and open it with notepad. Find the entry for Simlink and delete it. Problem solved!

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.