Pathway for install on Steam MSFS2020

Under #4:
You can install the Navigraph-Installer somewhere OUTSIDE of your sim folder. The folder which you choose will be created automatically. Important is only, that you select/enter a path NOT somewhere in your sim folder.

So, you can install it on C, D or whereever but NOT in D:\Steam, which seems is your sim folder (according your notes).

Hope that helps now … Simple install it somewhere on your system.

Cheers
Richard

Okay, when I direct the installation path to the D drive, it wants to know what folder to place it in. If I select ‘create a new folder’, it does so, but then hangs at this point;

You need full user rights for this folder. It looks, that you don’t have all. Add your current account into the administration group and you should be fine.

Create the folder via explorer manually and choose the path of this created folder in the setup. Possible that works for you.

Cheers
Richard

Sorry, I’m not clear how I ‘add my account to the administration group’. Is that somewhere on your website?
Or do you mean right-click the exe file and run it as Administrator? If so, I did that and it still hangs up.

Question: can the sim access the chart information if Navigraph is installed on a separate drive (like my C drive)?

No, that has nothing todo with us and/or our website, this must be done in your installed windows - this is a basic windows task, which you can do.

Have you tested my suggestion, to create the folder manually and then to point the installer to this folder?

The charts are completely independent from the sim and can also installed elsewhere.

Cheers
Richard

Yes, I have created a folder myself, “Navigraph”, and tried installing it in the C drive, D drive, and the Community folder, none of which has resulted in a successful installation. I’ve tried installing it with Admin rights (if that is what you were referring to–you still haven’t made that clear) also, with negative results.

I’ve uninstalled and reinstalled as per the directions elsewhere here without achieving success.

Although I was a dedicated Navigraph customer for years with FSX, I am getting frustrated with the difficulty required to install this product.

Is the the product incompatible with the Steam version? If the sim is installed on a different drive than the C drive, is there no way to make it work?

Brian,

Sorry to see, it should not be this complicated. Let’s try to get you going.

Please follow all steps in this instruction (but replace app name with Navigraph 1.0.0): FAQ - Charts desktop installer fails immediately

Then install it again, leaving the default path in the installer as default.

How does that work?

Regards,

Stephen

Hello Stephen,

Okay, so I uninstalled exactly as per the link. I then restarted my PC and ran the installer, again, using the link in your post (which is the default installer path. The only difference was that on my installation, the end folder said ‘Navigraph’, not ‘Navigraph Charts’).

The last step was when I was prompted to sign in (which I did) and this screen came up;

I assumed this means it was installed successfully.
However, when I start the sim, I create a flight to KAVX and check to see if the VOR approaches are listed. They aren’t, so I assume the installation did not take.

Brian,

That looks correct.

You could press the red Remove button, and then Install, just to be on the safe side, that action performs the data installation again.

Then, check this FAQ which will help you verify that the data is correctly installed: FAQ - Is the Beta Update Installed?

Can you confirm?

Regards,

Stephen

Hello Stephen,

The only step I had not taken was to press the ‘remove’ button. However, after having done that, I restarted the sim, and checked the three methods of confirmation as per your link—all indicated negative.

Did you press Install after Remove?

Yes, and I watched the process as it did the installation.

Your screenshot shows both Microsoft Store and Steam versions installed. Have you had a version from Microsoft Store installed before your current Steam install?

Could you post screenshots of the contents inside the two paths mentioned here? FAQ - Location/Path of content.xml package file

Thanks!

Stephen

Yes, at one time I had the Microsoft store version, however, my purchase of Navigraph was made long after I stopped using that version. Do you think Navigraph is pointing to that version? That makes sense to me.

Here are some pathways I found to the Content.xml;
D:\WpSystem\S-1-5-21-1622900022-245762873-1158802304-1001\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache

Also;
D:\Steam\steamapps\common\MicrosoftFlightSimulator\PublishedPackages

So this is the issue, we don’t support multiple sim installs (currently) and it is likely updating to Store one.

Is the MS Store one still installed? Could you uninstall it if you are not using it?

Stephen

Lol, so I uninstalled the store version (and Navigraph again), rebooted my PC, Re-installed Navigraph and…nothing.

Then I went into my D drive and found a folder named New FS2020 (which I’m pretty sure I deleted before the reboot). Looking inside it, I found a Community folder and inside that, I found ‘navigraph-navdata’. So I cut and pasted that folder into my Steam Community folder and viola! the data is in the sim now. At least most of it appears to be.

I did a search for ZBAD and it’s there, plus most of the fixes in the North Atlantic. I checked for the VOR approaches at KAVX and they are both there. Then I tried a flight to PAKW (which didn’t previously have any approaches ) and there are several now.

So the only anomaly is that I don’t see any title in my Content Manager.

Hi Brian,

I believe that perhaps the uninstall of the other simulator was not entirely successful, which also your “New FS2020” directory is an indication of. I would suggest that you try again to uninstall it. Is there not an entry in Settings->Apps ? You can also verify that the folder %localAppData%\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\ is not existing.

To have the navdata updated safely with every AIRAC update you need to use the installer
as manual workarounds are not guaranteed to work properly.

Kind regards,

Markus

Hi Markus,

Thanks for that information. I tried to delete that file and the system wouldn’t let me, even when I went directly to the Microsoft.FlightSimulator_8wekyb3d8bbwe folder. What’s the best way to gain permission to delete it?

How do you mean the system does not let you? Do you try to uninstall it normally using Settings->Apps&Features? What kind of error message do you get?

I would recommend doing this the “normal” way without deleting folders manually as the uninstallation process also deletes keys in the registry that is complicated to do by hand.

However, it sounds very odd that the folder is write-protected as AppData and all underlying folders should not have write-protection to work properly. To change permissions just right-click the folder, select “Properties”, go to the security tab and change the settings using “Edit” button so that it looks like this (for both your user and system). Verify that the AppData folder also have these permissions set correctly.

So I checked under the ‘Add/Remove Programs’ feature to be sure the store version of the sim isn’t here and I couldn’t find any indication that it is. Oddly enough, there are two entries for the Steam version, although they have different icons, but to sure, I clicked on them and at the bottom of the screen, it does say Steam.

Next, I went to the Microsoft.FlightSimulator_8wekyb3d8bbwe folder, right clicked it, and looked at the Properties>Security tab. Both System and my name have all options checked for ‘allow’ except special permissions (which is greyed out and won’t allow me to check it).
Nevertheless, when I try to delete the folder, it says;
‘You’ll need to provide administrator permission to delete this folder’

When I click on the Advanced tab, it shows myself, System and Administrators, double listed with ‘Allow’ and ‘Full control’ for all six entries: