Numerous charts issues

Opening charts desktop and web, the dropdown bar for the flight plan is stuck on loading flight plan.

Can’t create a flight as the create button is constantly greyed out.

Searching for an airport to look at the charts takes longer than ususal and than can’t even look at the charts anyway.

Same behaviour for desktop and web, which i tried it in vivaldi and firefox, and then edge with no extensions.

Tried signing out and back in, the identity api takes so long to load, and the page loads misformed.


Try disabling antivirus and firewall and restarting Windows. Please post sceenshot of “page misformed”
using Guide to posting Screenshots


made a video instead of the issues as there more than one. Can’t replicate getting a malformed page, but if it does happen again i’ll be sure to take a screenshot.

What type of network are you on? All issues you highlight in the video is because of the exteme latency it shows in contacting our servers. They reside on Amazon AWS so there is no performance issue in the backend. Logging in or loading a flight should not even take a second, for example.

Do you have a smartphone with a 4G connection? Could you try in it, to see if you can e.g. log in faster, and load a flight, and create a new flight? Just for comparisons.



Checked on my phone using wifi same issue, when i switch to 4g it works fine.

My network setup is a vdsl connection draytek vigor 130 bridged to a pfsense router, using cloudflare dns.

I’ve done a complete network restart modem router pc, and then did these trace routes.

Guessing my next stop is to contact my isp, which is werid as navigraph was working a few days ago and i haven’t made any changes to my pc or network at all.


It must be your ISP or your local network config that has changed some settings lately - we have not made any infrastructure changes, we are not able to reproduce, and no other users are reporting this at the moment. We rely on Amazon AWS as I mentioned and they are not reporting any problems. Your 4G connection test further points to an issue with your ISP or local network. I’d suggest you contact them and see if they can help troubleshooting.



Stephen thanks very much for the help.

Spoken to my isp and:

We are aware of an issue surrounding speed and latency issues on all sites utilizing AWS.

We are currently in contact with our UK upstream carriers as investigations appear to show there is an issue with one of our peering sessions with amazon. we have contacted them to check their side and continue to work with them on this.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.