Flight plans not loading in charts - problems signing in on navdata center & simlink

Hey everyone.
My flight plans on the Windows desktop application are not loading, this is the screen I’m seeing:

The iPad app works just fine but I’d love to be able to use the Windows Desktop app.
The windows app often fails to sign in as well, claiming network error, but my network is fine.

Navigraph Simlink also often times has an issue with signing in. The same with Navigraph Navdata.

All of these issues have started happening in the last 2 weeks.



Please uninstall, redownload and install Charts for Windows. Please restart machine.

Any improvement running Charts? If not please try accessing Navigraph Charts in a browser.


Hello Ian.
I have tried reinstalling several times and rebooting but the issue is still there.

With Charts on browser I’m unable to sign in, when clicking the sign in button nothing happens.

Additionally sometimes I’m getting sign in issues with Simlink and Navdata center, where clicking sign in does nothing.

I tried disabling the firewall to check if that was the issue but no luck either.

Are you using some anti-virus software, and if so, which?


Hello Stephen!
Yes, I’m using the default Windows Security antivirus.

I’d like to add some extra information; when I’m able to sign in Navigraph Charts on the browser, the same issue happens where no flight plans are loading (see original post screenshot).

On the browser I’m able to open the console, where I’m getting the following errors:

main.bundle.js:2          POST https://userdata.api.navigraph.com/ net::ERR_CONNECTION_TIMED_OUT

Another test - can you sign in to the main website navigraph.com?

Are you using VPN by any chance?



Signing in the website works fine, I’m not using a VPN.
All my other devices on the same network function fine, it seems to be something with my Windows machine blocking the requests.

Using a different browser also causes the same issue where it’s unable to request https://userdata.api.navigraph.com/.

I’ve changed my DNS settings on the Windows machine to Google’s and it immediately fixed the issue (Comenzar  |  Public DNS  |  Google Developers).

Hopefully this might be useful to someone else.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.