Maps not loading

Maps, airways, routes not loading, although individual charts will load, they will not overlay. Flights will import but not load all the way. Been like this couple hours so far. Attached you’ll find pictures.


Which version of the app are you running, check Settings?

If you restart the app, do the maps load?

If you sign out and then in again, does it work better?



Running Desktop version 8.20.0 build 4244959146. I’ve closed out/reloaded browser/site, signed out. No change.


Is it the same if you load in a browser on the same computer?



1 Like

To add a data point, I am having the same problem with on Chrome on MacOS. Started last night. Same build as the OP. However, tried to open the website in Safari and Firefox, and the charts display on both those. So it may be Chrome specific.

1 Like

I have the same issue since yesterday on my main browser (Opera). Restarting or logging out doesn’t help. However, if I launch new incognito tab, or use a different browser then the maps load ok. So it may be something related to cookies or other local settings.

1 Like

Hello everyone! Thank you for your feedback and sorry for the trouble.

We’re making some changes in preparation for an exciting release that will hopefully be published today. These changes are pretty sensitive to the cache stored in your browser, and you will get these results if:

  • Amazon AWS failed to clear their cache at your location
  • Your browser and/or app has an incompatible cache

Seeing as it works for one of you in a different browser, I’d say that #2 is quite likely to be the culprit. We’re currently investigating if we can work around this in a way that is more convenient to you guys, but in the meantime browser users can clear their cache/cookies which should fix this issue.

I’ll let you know when we have more information to share!

Kind Regards,

1 Like

Hello again! For those of you who are using, could you please confirm whether this issue still persists for you?

Had the same issue last night…charts loaded, simlink worked, but no map. Will try again when I get home.

Edit: just tried it here at work on Vivaldi, and it works. Not terribly useful information because I have no navigraph cache on this work computer, but at least I know it does work, and can troubleshoot when I get home.

1 Like

Now it works, thanks.

Will try on Firefox, as noted by @some1pl

@skysail Update: Can confirm all in working order on Firefox, is definitely Chrome specific. Will clear cache/cookies on Chrome (after I land a flight) see if that takes.

Update 2: Clearing cookies/cache on Chrome will resolve the issue. Thanks @stephen & @skysail and and everyone that chimed in so we could get this sorted.

This issue should now be fixed in both desktop and web, as long as both are on 8.20.2 or later.

Thank you for the feedback everyone!

1 Like

Thanks for fixing so quickly… chart overlaying on desktop version (PC / Win10) working correctly again after reading this post, logging out of the app and signing in again… :+1:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.