No option to update X-Plane 12 (macOS)


according to this No option to update X-Plane 12 the FMS Data Manager should should path in Settings for X-Plane 12. I just downloaded the Mac version from Navigraph and the setting is not there (I even deleted the previous one, downloaded new one just to make double sure).

Could you please verify if this is an issue on your end or on my end? I think the Mac version was simply forgotten alongside the Windows version (which works).

Thank you!

Not an issue now on the Windows version. The X-Plane 12 path was added to he latest FMS Data Manager.


I also have this problem on Mac OS. I am on an M1 Ultra Mac Studio and Mac OS 13 beta, if that helps narrow down a problem.

Similar problem here. Mac Studio, macOS 12.5.1. Just re-downloaded FMS Data Manager for Mac and now an input box is shown for specifying the X-Plane 12 path, but the file dialog does not work (it enters into the X-Plane 12 app package), and after typing directly the X-Plane 12 path and clicking “save” and “scan”, FMS Data Manager still does not find X-Plane 12.

Edit: The file dialog for the X-Plane 11 path is macOS native, while for X-Plane 12 a Qt file dialog is shown. Something appears to be wrong here.

Can anybody please confirm if they have successfully installed and updated their FMC in Xplane12 using a MacBook pro M1 chip please.
Iv’e tried all I can think of for a couple of days now, so a little advice would be very much appreciated. Thanks :slight_smile:


We just released an updated FMS Data Manager for macOS. Please download, install and let us know how you get on.



Appears to work, thank you! I’m not getting any out-of-date messages anymore and it says it’s valid until OCT 22.


Thanks for replying Ian but sadly nothing seems to work, and Iv’e now spent days trying to sort this.
I did contact accounts yesterday to cancel my subscription, but they told me to try here first for a possible solution.
Being an old person now lol, Iv’e really had enough to be fair, because I haven’t yet even began to enjoy using the new XPlane 12 for a single flight through messing around trying to update my FMC.

I know it’s this M1 chip causing the problem, but that’s way beyond my scope to sort out,

So thanks anyway Ian, at least we tried. :slight_smile:


Lets see if we can get this working.

For which aircraft in X-Plane 12 are you updating the FMC? Maybe post a screenshot showing the FMC ident page showing AIRAC dates using Guide to posting Screenshots

What steps have you taken? Have you installed the latest FMS Data Manager for macOS ? In the Settings page, do you see the correct X-Plane 12 path? Screenshots of this path help.

In Addon Mappings page, press Scan to get mapping for X-Plane 12. Do you get X-Plane 12 mapping:

If yes , in Addon List you should be able to select and Update this entry.


1 Like

OK, I finally got the FMS data manager detecting my XP12 installation, after doing this:

  1. Go to settings tab
  2. Manually type the path to the XP12 installation into the X-Plane 12 input box. The file picker does not work because “X-Plane” cannot be selected (the file picker sees the app package as a directory and enters into it).
  3. Go to AddOn Mappings tab and press “Scan”
  4. Go to Add On list tab. In this point, FMS Data Manager crashes for me (reproducible).
  5. Reopen FMS data manager. Now, X-Plane 12 is listed and FMS data can be updated.

After scan you need to hit Save, otherwise it crashes :see_no_evil:, but that didn’t change from previous version. :grinning:

works fine now, thnx

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.