FMS Data Manager Mac book

Hi there,

I’ve recently installed X-Plane 12 onto my laptop via Steam. As I have really gotten into it I decided to take things a step further by downloading FMS Data Manager however when I open the application on my Mac book pro it can’t seem to find any of the add-on mappings in order to update my AIRAC cycle. I’ve been looking through all these forums for days and still can’t seem to find an answer. any help is appreciated.

thanks,

sam

Hi Sam,

Welcome.

In FMS Data Manager Settings page,

Make sure you have installed the latest FMS Data Manager version:

In Path make sure your X-Ppane 12 path is pointing to your X-Plane app. Use the black folder to navigate to your X-Plane app.

In Addon Mappings page, you should be able to Scan for X-Plane 12 and X-Plane 12 addons.
In Addon List page, you should be able to select and Update X-Plane 12 and X-Plane 12 addons

Cheers
Ian

Hi Ian,

My path settings are blank however whenever I try to select the X-Plane app it won’t select it it will just take me into the app folder if I try to manually type the path settings in it disappears when I save settings?

Cheers,

Sam

Hi Ian,

Can you Specify for me what the Path settings are so I can manually type them in. The clear problem is there is no path however I can’t seem to figure out what the path is? What would it be for Mac?

Thanks,

Sam

Hi Sam,

This depends on where you have installed it.
Please use Finder to search for the folder of your X-Plane app, and copy and paste that folder name into the path for X-Plane 12 in Settings.

Cheers
Ian

Hi Ian,

I have found the folder and pasted the name into the X-plane 12 path box however when I save my settings and then switch over to the add-on mappings page I scan and nothing gets found. when I go back to the settings page the X-Plane 12 path box is Empty again. I click save settings every time however it still empties.

is this a fault on my end or your end?

We are investigating and will get back to you.

Cheers
Ian

Hi,

In FMS DM go to settings and set the XP12 path to the X-Plane 12 textbox as per the below image.

FMS DM → settings for Simulator Path Textbox is also supporting for manual change in the path. so, you can also type the correct path.

NOTE: In your case, you have to set the path folder where the X-Plane.app application file is located.

After setting the correct path just save the settings and rescan the addons from the Addon Mapping button
image

Please feel free to inform us about any issues with the Navigraph Product.

Happy Flight :slight_smile:

Kind Regards,

Vishal Ahir
Navigraph

I am having the EXACT same problem on my Mac. What is strange is that it worked fine before I recently deleted and reinstalled XP12.

After hours and hours of struggling with this issue I just solved it. Here is what I did: Using Finder, got to the main XP folder and right-click it. Screenshot below. Highlight and copy the path. It will ask you if you want to copy it as a path. Do that. Then past that into the XP 12 path box in the setting of the Data Manager but MAKE SURE you add /X-Plane 12/ to what you just pasted there. Do not forget the forward slash at the end. IF the path is not perfect you can hit save all you want but it will disappear from the box and you’ll have to start over. The path must match identically. As soon as I did this the scan feature found all my add-ons and I was able to update everything. Happy days! I’m going “flying”.

Still do not understand why the Data Manager file picker box will not accept the proper path when I navigated there. Perhaps Navigraph can look into why we are forced to manually type it in.

My path looks like this:

Hi,

Just to understand this a bit better, after reinstalling XP12, did you actually run it once before attempting to update via FMS Data Manager? Or did you try updating the data in FMS Data Manager before you started XP12 the first time after reinstallation?

Stephen

Have you actually been running XP12 at least once after installing it (before attempting to update the data via FMS Data Manager)?

Regards,

Stephen

I ran it loads before this issue however it is solved now thanks to Vishal!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.