Navigraph update not appearing in X-Plane 50+ x-plane 530, default FMS, etc

I have updated my Navigraph to cycle 2013 using the data manager but when I open an aircraft for a flight the latest AIRAC cycle (2013) does not appear on the aircraft GN 530, laminar default FMS or my MD 80. It shows this cycle: 15AUG19-12SEPT19. My CIFP folder is showing date: 8/16/2019 data file. My updated GNS folder shows AIRAC cycle : 2013 Version : 1
Valid (from/to): 03/DEC/2020 - 31/DEC/2020. See my photos.


Welcome to our new forum.

Unless you have specific past saved airac’s, lets start from scratch.

Please disable any Antivirus and firewall.

Please use Windows to uninstall FMS Data Manager.

If they exist, please delete folders:
c:\ProgramData\Navigraph\FMSClient and c:\Program Files (x86)\Navigraph\FMS Data Manager.

Please download and install latest FMS Data Manager .

In Settings check you have correct path to X-Plane .

In Adddon Mappings tab, Remove X-Plane 11 entry, press Scan and you should now have X-Plane and X-Plane addons with correct mapping.

Select and download X-Plane and X-Plane addons in Addon List

If still a problem, please post screenshots of FMS Data Manager Settings tab, showing Version number and X-Plane 11 path , and Addon Mappings tab showing X-Plane 11 addons and their mappings.


Thanks Ian. I followed your instructions and it worked, problem solved. Regards, Lewis

Hi Lewis,

You are welcome. I shall mark topic as solved.


This sounds like my problem too, only I run on a Mac and the specific X-Plane FMS data doesn’t want to update beyond version 2011. Other individual planes like the Rotate MD80 and FF A320 have updated ok. Do I follow the same instructions and is there anything I should delete which is different from a PC. Thanks in advance for your help in this.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.