Navigraph Logs out if using SimToolKitPro

For the past few months I’ve been using SimToolKitPro to consolidate tools. Navigraph consistently logs off whether using X-Plane or MSFS. It does not make any difference if the MSFS plane has a Navigraph link or not. Over the past few months I have gone through several updates of STKP as well as updating X-Plane and MSFS and the Navigraph Simlink, but the problem persists. Can’t find much on the forums, and posting to STKP discord I was told that the issue was with the Navigraph Token. As a verification test I quit using STKP over the past week - flying a dozen or more flights on X-Plane and MSFS in a variety of situations and may have had 1 log off of Navigaph. I used Avitab with X-Plane and the built-in Navigraph link with Working Titles CJ4 and no problems. With STKP I rarely (if ever) complete even a short flight without Navigraph logging out. If Avitab and working titles can access in-sim why can’t STKP access outside of the sim?

1 Like

Which app/software logs off more specifically?

The only thing I know you can’t have two concurrent sessions of on the same machine is Charts Cloud, and I know STKP wraps Charts Cloud. So if you also run it in another browser, it will likely log off.

WT and Avitab implements our Charts API, are not wrapping Charts Cloud, and are hence not affected.

Are you running Cloud in a separate window, and if so, why, when you have it in STKP?

Regards,

Stephen

No, I only have simbrief and STKP in my left monitor and MSFS or X-Plane in the other. I get a prompt to log back in to Navigraph in STKP. Sometimes I get a few hours of flight before I get logged out. Today it was about 15 minutes. I’m not running charts separate. I can record my next flight, or?

Thanks

Ok, yesterday’s 1 hour flight on MSFS was fine (of course that’s the one I recorded). Today I had a longer flight on MSFS Copenhagen to Cairo with the Flybywire a320 neo. About 5 minutes into the flight Navigraph (in STKP) popped up to login. I did, and the rest of the flight was fine.
Running:

MSFS
A320 Neo
STKP
Pushback tool
VirtualUA SmartCARS

Second flight:
Exited MSFS, started X-Plane and loaded Flightfactor 777-200. Created my flight plan using SimBrief and saved the flight plan. I was going to wait to start recording until I finished entering the flightplan, but I just got the plane set up for refueling and loading passengers when I got logged out of Navigraph and prompted to login again.
Running:
X-Plane
STKP
VirutalUA SmartCARS (scheduling/client tracking)
ActiveSky weather

I’ll start recording this flight - but all it will show is the login page for Navigraph within STKP.

Could you do another experiment please - do not use Navigraph Charts inside STKP for the next flight. Instead use Charts Cloud (https://charts.navigraph.com) in Chrome.

Does it show the same patterns?

Stephen

I’ll do that next flight. I ran a week not using STKP last week to verify if it was STKP, and didn’t have any logouts. I’ll do that again after my current flight. Another logout on the flight I’m on now (Same flight as I reported last).

3 flights for testing. I downloaded Chrome, but forgot to use it (I took it off and switched to Opera). I’ll use it tomorrow; but here’s the results:
X-Plane, Navigraph charts, VirtualUA SmartCars, Active Sky (same setup). Cairo to Vienna (Flightfactor 777-200 - 4 hrs); Vienna to Stockholm (E-Jet 170 2 hrs). MSFS A320 Neo (Flybywire) Stockholm to Brussels (2 hr flight).

No disconnects. Not one in 8 hrs of flight. I’ll use Chrome tomorrow but I expect the same results.

Thanks for your assistance,

Jeff

P.S.
I’m so used to using Navigraph for Windows that I forgot the reference of Navigraph Cloud (web based). I was just thinking about the last email from you and your reference to Chrome, and I made the connection. OK. I’ll cloud with chrome tomorrow so we have 2 examples of web use.
jle

Ok, we’re onto something here. I flew a 2 1/2 hour flight in X-plane, and Charts in CHROME worked fine. I shut that down and switched to MSFS after loading the beta version of Navigraph Simlink for MSFS. My location/plane showed up on the chart - linked OK. Then I had to walk away from my desk for awhile, then had some issues with MSFS (entering a flight plan). Restarted MSFS - and the plane still showed up in Navigraph Cloud charts (still at the gate). Again I had MSFS freeze from a flight plan entry and restarted MSFS. With the third restart of MSFS Navigraph Cloud Charts would not connect with a “could not connect to simulator” message.
Task manager shows 3 Navigator programs in the listing and simlink - not certain if that means anything.

Let me wrap this flight up and I’ll try a fresh 3 flight tomorrow using both x-plane and MSFS hopefully with less MSFS issues. Just for grins tried Navigraph for Windows and it gets the same message.

The issue I was having with MSFS/Flybywire may be a Navigraph issue unrelated to the connectivity issue. Here are my notes to the flybywire discord
*
I am unable to enter a full flight plan. I’ve flown the flybywire probably 10 times at least, and not had this problem. Three times I entered manually, and twice attempted direct simbrief. LDZA/LPPT with route of KOTO1V KOTOR DCT RJK DCT NAKIT DCT LABIN DCT LURUT DCT GOLAS DCT ENOBA DCT BORDI Z185 BADBA UZ185 KOLON UM984 BISBA UN975 BGR UT410 ARBEK DCT OSLAP UN975 CCS DCT EXONA EXON8A generated by simbrief. Twice I entered the flight plan up to ENOBA and then it froze. The third manual attempt I entered and inserted each waypoint and it died at ENOBA. When I said “died” the SIM freezes. I have to end program using task manager. When I try to import Simbrief I get “not in database”, “Not allowed”, “uplink in progress”. Using Simbrief only flight plan nothing from MSFS. This is the first time using the uplink feature, but I always manually enter flight plan - many 3 or 4 hours with lots of waypoints. - Wait - it finally came back after ENOBA entered after about 5 minutes. Let me chug along… Sorry - I’m usually patient, but 5 minutes with a complete Sim freeze is strange. Ok… update: got the flight plan entered. Just took FOREVER to add ENOBA.*

It is similar to

Jeff

Jeff,

Ok, but backtracking to the original issue, when running Charts Cloud in Chrome or any other browser, it works as expected? If so, I can only recommend you to use Charts Cloud, or our native Desktop app which can be downloaded from Navigraph

As for the other issue, I’d recommend you to post that as a separate issue, or add to the issue you linked to above, as it has nothing to to with the app logout.

Regards,

Stephen

Hello Stephen,
I have the same issue. Tried as was written above with charts cloud in Chrome. But the same thing happened. The connection with Navigraph was lost and I had to sign in again.
So just maybe it is not an STKP thing or XP or MSFS, I don’t know.
Lucky for me / us is, as soon as you sign in, the right charts and route are back. So no data is lost. Does this help you?

experiencing the same issue with STKP and p3dv5 … after a while I need to sign in for the charts again … used to work fine before

Because of the issue I ran into with MSFS/Flybywire I was unable to test yesterday. I am switching flights between X-Plane & MSFS; so I want to test that behavior. Getting ready for my flights today; hopefully with better success.
Jeff

I reinstalled the Navigraph+Simlink again. Same thing happens.

Hi all,

So we have a few different cases here now, e.g. using STKP or not, using Simlink or not.

Please do not use STKP for now and use Charts Cloud only. Make tests with 1) moving maps enabled and 2) moving maps disabled.

Please report if you get regularly signed out from Charts Cloud using either 1 or 2 above, or both.

Regards,

Stephen

Moving Maps Test:
Wednesday

  • ESSA-EBBR MSFS Airbus A320 FBW (4 hrs)
  • EBBR-LDZA X-Plane Dash-8 (2.25 hrs)

Thursday

  • LDZA - LPPT MSFS Airbus A320 FBW (4 hrs) {Took 3-5 minutes to load ENOBA waypoint}

  • LPPT-LEMD X-Plane Zibo 738 (1.5 hr)

  • LEMD-LPPT MSFS MSFS CRJ 550 (1.5 hr)

    13 minutes in to LEMD-LPPT - Disconnected from sim, not responsive when clicking connect. Exited Chrome, and restarted; connection re-established.

Friday

  • LPPT-EDDF MSFS A320 FBW (3 Hrs)
  • EDDF-EDDH X-Plane Toliss A319 (1 hr) (Plus left connected at gate for 1.5 hrs - no disconnects)
  • EDDH-EDDF X-plane Toliss A319 (1 hr)

Summary

  • MSFS 12.5 hrs of flight
  • X-Plane 5.75 hrs of flight
    No permanent disconnects

I have an 11+hr flight with x-plane (test) tomorrow.

I guess my question is… is/can Navigraph work directly with STKM for resolution?