Navigraph client will not launch

I have downloaded the beta v. 19 and installed. It indicated that it had installed. But when I attempt launch the client (Navigraph) it flashes for a milisecond like it is starting and then nothing. I have deleted and re-installed several times to no avail. What am I doing wrong.

look at the windows “system tray”. This application runs behind as a kind of service.


Does the application need to be running after you download and install the Nav Data, or can /should it be terminated?


No Joe, you can close it after the installationen/update of an AIRAC cycle. The application will not be needed for anything else (at least in the current beta version).

Hope that help, have a nice day

hello Richard…

need some help…downloaded latest MSFS client but it will not install

any help would be appreciated

Hi Daciel,
what do you mean with “will not install”? Do you see an error message? Does the program install but not will not start? Or what do you mean? Which OS do you us?


I’m also having some difficulty with the install process. I’m trying to migrate everything to another drive, but during install of the navdata client, I get the following error:

‘Error opening file for writing: %Install path%\Uninstall Navigraph.exe’

There is no such file there, and as far as I can tell not in any other location. Choosing ignore allows the setup to continue, but it appears that the install is not taking place.

The app is listed in the uninstall program list, and a desktop shortcut is being created, but it points to an invalid target (Navigraph.exe in the install directory, but the setup process is not changing anything in the install directory).

When I choose uninstall in the control panel app, it generates an error as well (program is listed as 'Navigraph 1.0.0-beta.19). Error on uninstall is "…It may have already been uninstalled. Would you like to remove from the Programs and Features list?

OS is Win 10 Home

sent some pics
win 10 fully updated…did not have issues with other clients
all was working well until trying to install client 19

Hi again,
thanks for the screenshots.

Please, install the Navigraph-Installer OUTSIDE of your flightsim, somewhere else and NOT in the community-folder of the sim. The Installer is “only” to install the AIRAC updates into the sim (and here in the community-folder but that´s a task of the Installer).

So, try to install the Navigraph Installer somewhere else, where you have fully rights with your user but please not in any folder/subfolder of your sim.

Let me know, if this help …

The screenshots above are similar to the error I got on initial install, should have mentioned. However, the install path was not in the MSFS directory path, and I had full rights to the install folder. My description above was what resulted in subsequent attempts to uninstall/reinstall.

Thanks for the reply…yes i did try to resolve it by doing what you suggested but it
still did not work,same error message
Ater a couple of hours messing with it i looked at my apps list in control panel
and noticed that client 14 was still there so i uninstalled it manually
and retried installing client 19…and wow…wow it worked nicely

Thanks for your help…much appreciated

1 Like

Great, yes this is can also be an issue, when a old/outdated Navigraph Installer is present in your system.

Thanks for your feedback and also your time to share your experiance with us here. Mich appriciated.


PS: I will add your solution in the install FAQ

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.