Navdata Center issue

I’m still having this issue. I use chrome by default but I just installed Firefox and had the same issue.

Is there a way to open an event viewer to see where the issue might be?

I’m having the exact same as jbrooks2. I have uninstalled and reinstalled. It is just stuck on the sign in page. It like the page is totally locked up. I have done all of the firewall disabling with no results. I’m out of ideas! please lets get this solved ASAP!


Which is your system default browser? Could you temporarily change it to some other browser and try again?



System default browser was Microsoft edge. Believe me I’ve already tried switching browsers because that was suggested earlier! The app is totally locked up. I’ve uninstalled a couple of times and reinstalled with no results. Are other people having the same issue because it sounds like they are?

I have been using the Navigraph data center since August of last year with no problems. When I went into it this morning to try to do an update, it was like the whole thing was locked up and everything on the right side of the screen. I was not able to update, went to the forum to see what I could find out. I then uninstalled and reinstalled a couple of times change browsers with no results. If you have any more suggestions, that would be great just looking to get this solved thanks for your help!

Yeah I’ve been using it since November and no problems until early this month

Stephen, I appreciate your replies! Is there some other way to update besides using the NAV data center?

If there is not, then we need to figure out a way to fix this problem otherwise the subscription becomes useless! Not trying to antagonize, just trying to come up with solutions! Hopefully we can solve this!

I appreciate any suggestions you may have!



1 Like


Please check Malte’s post here and follow the link at the end of it, to read about some possible solutions.

Let me know the outcome.



1 Like

I also was blocked when I tried to log on to the Navdata application. The log on page would simply freeze despite receiving a message through my Firefox browser that I was already logged in to Navigraph!

The solution:
1 - Go into Firefox settings, then select the “General” icon in the upper left-hand corner.
2 - Scroll down the page to the “Files and Applications” section. In the Applications box, you should see “Navigraph-desktop” in the “Content Type” column.
3 - The corresponding Action should be “Use Navigraph Navdata Center (default)”


In my case, it indicated “Use Firefox” and this is what caused the error. Once I made this small correction, the Navdata Center worked perfectly.

I hope this helps.

I use chrome, is there a similar process, or should I just try it on Firefox?

Unfortunately it didn’t show up in that menu.

There was an option upon installation as to what application should be used/linked. If it doesn’t show up at all as in my second screenshot, try uninstalling and then reinstalling Navdata. That’s all I could suggest. I admit that I was going crazy trying to figure out why this app froze. Few clear solutions out there.

Good luck!

I installed Firefox on my computer. Made it the default browser. Then did a restart on my computer and it started working!

I would definitely give that a try!

Did you uninstall and reinstall navdata center?

Yes I did! The only other thing I did was run Malwarebytes. Then I uninstalled Navdata Center then reinstalled it. After that, I installed the fire fox browser and made it my default browser then done a restart on on the computer. It immediately started working for me after that. I have no clue why it started working but it did.

When I select “General” in Firefox and scroll to “Files and Applications”, Navigraph-desktop is not listed nor is "Navigraph Navdata Center. The only one listed in the Content section is "Use Navigraph Simlink.

1 Like

My mother suggested my c drive is too full. About 5 gb left. That can’t be it, can it?

Version 1.1.0 and subsequently 1.2.0 has been released! The changes that are included in these updates should hopefully get rid of the majority of the problems related to signing in.

If you are still not able to click the button, try pressing Tab ↹ to highlight the button and then press Enter ↵.

Try it out and let us know if the situation improves!

Kind Regards,

Thank you again for your help!

1 Like