Navadata center sign-in button greyed out

I am reposting this because my previous post had a technical issue and did not appear correctly.

      I am unable to login to the Navigraph navdata center program. When I start the program, I get a white screen with a blue button that says “Sign In,” but the button is greyed out and nothing happens when  I click on it. I have tried all of the solutions I can find on the Internet and the forums, including multiple re-installs of this program. I tried deleting all references to the program from the windows registry and all files related to the program, but upon re-install it still does not allow me to sign in. I have seen statements from Navigraph that this issue involves some sort of issue with a firewall or local network, but I cannot find anything that is blocking the navdata program from starting up or allowing me to sign in. For troubleshooting, I tried logging in from another computer and I was able to sign in.

The Navigraph charts program appears to work fine. The FMS updater program appears to work fine. I am able to open charts from within aircraft within the Microsoft Flight Simulator (although I get only a blank screen when using the Navigraph charts feature of the PMS GTN 750). I am updated to tAirac 2301, but I as I understand it a new Airac was released on Feb 23 .

The Navdata Center originally worked fine with my installation. Of course, there have been many official updates over the last couple of months. I am not sure when it stopped working, but it has been some time ago.

Any suggestions are appreciated. This seems to be a local installation issue, but I have no idea what else to do to troubleshoot it.

Hi Jfreed1000,

I have added additional logging to your account. Please close down the program totally (by right-clicking the icon in the system tray) and start it again. We will then be able to see on our side how the app is behaving.

Kind regards,



I have followed your instructions. Closed program through taskbar, then restarted it.

Thanks for your assistance with this. I have been a Navigraph subscriber for more than 5 years, and have never had any issues until this came up.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.