MSFS 2020 "... cannot detect a flight in your simulator"

PSM GTN750? Forgive my ignorance please.

GTN™ 750 | ADS-B | Garmin
GPS for MSFS2020 (pms50.com)

It’s a third party implementation in MSFS2020 of the Garmin Touchscreen Navigation (for GPS/NAV/COMM/MFD) including flight planning, moving map and charts, etc. It’s available on a number of aircraft and is factory fitted on H145 Helionix.

Same here, Insider 1000.22483. Get a 401. The insider is valid until Sep 2022. Maybe the main release Windows 11 willl have the same issue soon.

@lanehoy, @Timothyed, @gringo85, @Drifter906, @fremote

I´m pretty sure, that this has nothing to do if you are using the Preview or not because as you see on the example of Driver906 - he is not using the Preview and it´s also not working. But on the other hand, you see the Simlink works as expected on my screenshot from my system, which has exactly the same version as the version from Drifter906.

So, it´s any other setting, issue but I´m pretty sure not the version per se.

Therefore, we need a few additional information:

  1. Has Simlink worked before? When yes, when (with Win10 or also Win11)?
  2. What browser do you use, have you installed (Firefox, Chrome, Edge, …)?
  3. What Internet connection do you have and have you a firewall between your router and your PC?
  4. Do you use a LAN or only a single machine?
  5. Is Simlink installed on the same machine as the MSFS is installed?
  6. Do you have any other sim installed and have you tried if Simlink works here (like FSX, P3D or X-Plane)?
  7. Which MSFS version do you have (Marketplace, Steam or CD)?
  8. Do you have uninstalled/reinstalled Simlink, like the instructions from Ian´s posting here (and I mean really, exactly these steps!) - please do all this steps, when the MSFS is NOT RUNNING!
  9. Please, try to start the MSFS again and upload the lastest 2 dlog-files here

Thanks for your help
Richard

HI,

Please check the above-posted FAQ and also check some additional troubleshoot points which are as follow,

  1. Check the environment variable is correct or not from here.

  2. Check system time auto-sync is enabled or not. (It must be enabled)

  3. During Windows upgrade it may corrupt Simlink configuration, so please follow below steps to reset the Simlink configuration files,
    a. Close running Simulator and Simlink.
    b. Open the “RUN” window by keyboard shortcut “Win+R”

    c. Now paste this path (%appdata%/Navigraph") to the Run window and click on the OK button.

    d. After opening the #c path, please take a backup of the Navigraph folder and delete it.
    e. Now start the Simlink application, and Simlink will set the default configuration for the application.
    Note: After reset configuration, Simlink will ask for Navigraph user to log in again.
    f. After resetting the configuration, please reinstall the Simlink plugin for Simulators. (No need to install a plugin for MSFS 2020)
    g. Please, start Simulator and check moving map functionality is working or not.

Please let us know if you face an issue after applying the above troubleshoot points.

TR,

Ahir Vishal D.
Navigraph

… additional to Vishals answer, I have written a short description for Windows 11 in the FAQ:

Hopefully, all these information can fix your issues.
Cheers,
Richard

First of all, many thanks for this great support!
Attached the latest log after reinstallation according exactly to your guides.
The paths are also perfectly there.
To answer the questions from Richard:

  1. It’s a new installation which has never worked before.
  2. Firefox is default. But tried also the login with Chrome. The login works perfectly.
  3. DSL with Zyxel USG 310.
  4. LAN
  5. Simlink is installed on the same machine as the MSFS2020.
  6. No other Sim.
  7. Marketplace
  8. Yes. Several time.

simlink_2021-10-25.dlog (2.5 KB)

Hi Richard,

I did this all again, exactly as per your thread. No change. Still like this:
image

FYI Little Navmap finds the flight and aircraft location also.

Does this work with Navigraph as moving map?

Little nav map will show your planes location. But not with the integration of a Simbrief flightplan overlay or chart overlays of all Jeppersen charts. So not really a replacement for moving maps. I must confess though as to not trying Little Navmap. I welcome corrections to my assessment. Still miss my moving maps. I hope this thread will soon contain some kind of resolution. All recommended fixes tried.

1 Like

Any updates on the matter yet?

Not yet apparently. :unamused: I’m still hopeful. Too busy to try again till maybe Thursday or Friday. Sometimes these things “just start working”, like it’s on the server side. Please update the thread if you see any positive signs, as will I. Maybe LaneHoy could weight in? He seems quite knowledgeable.

Hello All,

We are investigating an issue with Windows 11. And we will post a solution soon.

TR,

Ahir Vishal D.
Navigraph

2 Likes

Thanks Ahir. Good luck, we’re all counting on you.

1 Like

Godspeed Ahir !! Best of luck !!

Hi gentlemen,
just a short update on this. As Vishal wrote, we are working on a fix, but I will explain what happened:

We use a special “tool” in Simlink to “identify” the MSFS and to “talk” with the sims. This API is removed from Windows 11 build 22483 or higher. In the current official Win11 release build 22000, this “tool” is still existing, therefore the reason, why Simlink works on some systems and on some not.

The bad news here is, and that´s also the main reason, why we must fix this immediately - this tool is (or will be) also removed on Win10 systems from any 21H1 update on. We have currently a lot more Win10 user as Win11 therefore the change is important.

But in general:
Normally (not in the past, nor in the future), we don´t official support any “beta/preview/dev/experimental” versions. Not for OS systems, nor for any addons. A preview version is not a final one and issues/errors may occur.

In this special case, this is really an “immediately fix” which we must build and also we are very thankful for all the comments on this and also for the possibility of the remote-session between one of our customer and Vishal.

We will keep you inform here, when the fix is done, tested and ready for the release.
Thanks to all for their patience and also the effort to help us to find the issue

Cheers,
Richard

3 Likes

Hello Richard.

Vishal updated my system, all good for now.

Fully understand that you don’t support preview builds, but of course knowing what will not work down the line is as important for your company as it is for mine, I imagine.

BRGDS, Lane

Were you a guinea pig for a test fix? Just curious.

Gentlemen,

We have now released the new Simlink version, which looks good now for all systems and in all sims, incl. Win11 preview with MSFS. Our tests are not as relevant as your tests :wink: So please, update your Simlink and try if the Moving Map now is working again.

How do you update Simlink?

  1. Before you do anything, please close all sim´s - VERY IMPORTANT TASK!!!
  2. Close Simlink (taskbar - right click on the Simlink symbol and select “Quit”)
  3. Start Simlink (simply look for Simlink via the search-function in your OS)
  4. Simlink should start now and you should immediately get the following message:
  5. Press YES → the new version will now be downloaded automatically in your %userprofile%\Downloads
  6. Go into this folder and double click/start the Navigraph-Simlink.exe
  7. The update process will be started and you need only go forward during the setup. No changes necessary.
  8. After the installation is finished, you should see this windows to confirm that all sim´s are updated with the newest version.

    Attention! You will not see the MSFS because for the MSFS there is no own plugin - the MSFS communication works directly with Simlink.
  9. Press ok, and “Launch Simlink”.
  10. Start your sim and enjoy it :wink:

Any comments are welcome
Cheers,
Richard

1 Like