Maps not loading properly


Not anymore. I don’t know if it had anything to do with the answer I’ve got from navigraph or not. Either they did something, or it just fixed itself. Never had the same issue again.
The issue seemed to be app related only (I don’t recall trying anything different).


We have not made any changes yet, so then it was something temporary between you, your ISP, and AWS (our service provider) in your case. That’s good to hear!

The problem seems to be intermittent. I’ve only seen the problem on the macOS app. The problem doesn’t appear using the browser on the same device, ISP, time, etc. I’ve seen the problem on the order of hours to days. I’ve tried logging out and reinstalling the app and didn’t see an improvement. It’s unclear what fixes the problem besides just waiting. Perhaps the fact that the browser works on the same device while the app has the problem would be a potential lead.

It’s quite puzzling really. The logs show that you are making requests as if you were not signed in, but you obviously are signed in, or else you would not be able to see the map.

Please try with this version (pick your platform). Any difference?


I noticed the problem again today and just tried version you posted yesterday. The problem didn’t occur.

That is very interesting! The version I provided has the cache entirely disabled.
Please try this version out for a while and see if you ever get the same issue again! Let me know when you feel like you have tried it out long enough to determine that the issue is gone.

I feel pretty confident that the version with the cache disabled works around the issue, but I’ll let you know if it happens again this week. I would like to use a fully supported/signed version long term. Any thoughts on developing a standard solution?

One thing I wanted to mention is that I often jump between ISPs (work & home) and use different VPN connections. I usually just leave Navigraph open throughout the day. I’m not sure if that’s related, but it’s the only thing that comes to mind that might be unusual compared to most users. When the problem occurs, I’ve tried restarting the app and even reinstalling the app with no success.

But again, the no-cache version seems to workaround the issue.


Sounds good!

Of course we’d like to make sure that it is fixed for everyone, even without a custom build of the application. We just need to narrow things down first - I still don’t understand why your computer is caching failed requests to our servers…

Moving ISPs could actually have an impact, but from our side it does look good at least…

Looking forward to your report!

I noticed the problem again on build 7613181962, restarted the app => same problem, then tried the no cache build => no issue.

Thanks for the report! Could you stick with the nocache version until the next release? It contains all the same things as build 7613181962, so you should be fine. I want to make sure that it works in the long run too, but so far it does look promising!

Today this issue again back, has occured within last 2 hours between my previous and now under planning flight. Waypoints, airways, grids etc not completely loading. Windows desktop version only in use.

Different drawing issue in different zoom levels.

Were you using the custom build provided here?

Nope, always using only published official version and updating via Charts own update system.

That’d explain it then. Looks like you are having some sort of cache issue too.
We’ll see what we can come up with when resources become available!

1 Like

We have changed our caching policies, and this situation should now have been vastly improved.

I will assume this topic to be solved but will leave it open. Let us know if you see this issue again!

Kind Regards,