Maps not loading properly

Since today I can’t get my Navigraph App to work on my MacBook.
I tried to reinstall it and reset it but without any success. The graphics of the map are all over the place.

As you can see in the picture above the map is absolutely useless the way it is shown.

Hi @Aviator175,

I can confirm that something is off with the route visualization in the Desktop app, we are investigating. Will update you as soon as it is solved.

Kind regards,


Hello @Aviator175 ! Welcome to our forum!

I cannot reproduce this in any version of Navigraph Charts, including macOS.
That said, we have seen cases like these before! So far, it has always come down to a broken cache - either on your computer or at the edge node closest to you.

The latter explanation sounds the most likely, given that my colleague @m4rkus was able to reproduce the issue. With this in mind, we have now sent a request to our cloud provider (Amazon) to clear out any related caches - please try again now and see if the issue is still there!

Kind Regards,

Same issue here, since today morning. Have restarted Charts and whole computer, nothing fixes it.
Version: 8.32.0
Build: 7613181962

Do you have the same issue in the browser version?

Whhat ISP do you have?

Kind Regards,

Nope, only Windows application version in use. And it also started working again approx 5min ago.

Thanks for the update! Then it was either cache related or a temporary connection issue between your ISP and Amazon servers!

1 Like

I’m having the same issue. Unusable on macOS at the moment. iPhone is working fine. Is there a way to delete the cache? I tried deleting the the app from the application folder but had the same issue after restarting.

It’s working again. It was unusable for at least an hour. Hopefully this isn’t a common problem.

It shouldn’t be. To clarify, we have not changed anything and what you were seeing must have been a cache hiccup somewhere between our servers and your computer!

We have still not been able to reproduce any of these issues, which points to regional issues. We use a top-tier Content Delivery Network with hundreds of different server locations, so it is entirely possible that this issue would affect a specific ISP (and its users) and nobody else!

Kind Regards,

I’m seeing this again today.

Let me know if there is anything I can check to help troubleshoot this.

Note that it works fine on my iPhone running on the same wifi. And macOS device is working fine in Safari using Navigraph Charts. If it’s a regional issue, then I’m not sure why the same device on the browser and iPhone on the same network are running ok. The problem seems specific to the macOS app. I tried deleting the app and reinstalling it as well - same issue appeared.

That’s peculiar!

I have enabled some additional logging for your account. Please try to reproduce this issue in the desktop application and let me know if/when you see the issue again!

Kind Regards,

Im having the same issue since yesterday. Windows app.

Hello! Sorry to hear that.

I have enabled some additional logging for you too, so please start the app and let me know if/when you see the issue again!

Kind Regards,

Hello, sorry for the trouble but I am also experiencing the same issue on the MacOS app. Tried restarting and reinstalling the app but nothing works. Able to assist in this, thank you!

I have added additional logging to your account as well. Let me know if you see this issue again!

Hello, I’m seeing issues again.

Thanks for reporting back!

I can see your logs, and it looks like something is preventing you from fetching fonts from our server.
When this issue occurs again, could you try signing out and then in again to see if that fixes the issue?

Kind Regards,

Unfortunately I’m still seeing the issue after logging out in macOS app. Thanks for looking into it. Let me know if there is anything else that I can try. I confirmed that the same saved flight loads properly in Safari using

@here Are you all still seeing this issue? And most importantly, can everyone confirm that this is only an issue in the desktop application, and not in the browser or native apps?

We’re trying to narrow things down, but none of the logs we have seen so far make any sense unfortunately.