Live aircraft status doesnt work in MSFS2020

Hello all

Yesterday I got a month sub on Navigraph and it is amazing! Only thing I did not get to work yet is to display my aircrafts location on the map/charts.

I downloaded simlink but it still does not work

Also the only way to open the menu where you can see the simlink status is to reinstall it. Otherwhise if I just click on simlink it wont open a new window, it just opens the program without showing anything.

image

Hello Emiel! Welcome to the forum.

In order to open the Simlink application interface, please have look in the taskbar after starting it and click on the Simlink icon. Here’s a screenshot for reference:
image


Once you press that, a window like this should appear. Among other things, it shows you the status of your connection to the simulator. Please run MSFS2020 and make sure that the status in Simlink goes from Not broadcasting flight data to server to Broadcasted flight data to server successfully. Here’s another screenshot:
image

If the status does not change at all when starting the simulator, please let me know and we’ll troubleshoot it together.

Kind Regards,
Malte

1 Like

Hi @skysail

Thanks for your reply.

Just got to open the status page yes, however it still stays on not broadcasting flight data to server whenever I start the simulator

Hello again!

Please have a look at this answer from another developer:

If that does not work, please attach the latest Simlink log in your next post. To do this, follow these steps:

  1. Press + R to open Windows Run
  2. Paste the following string and press OK: %appdata%\Navigraph\Simlink\logs\
  3. From the explorer window that opens, select the file with the latest timestamp and upload it here

Kind Regards,
Malte

1 Like

Alright I tried it. restarting the sim now. Should the broadcasting to server only be on once spawned in or also on the homescreen of FS2020?

We have an issue where it will broadcast an incorrect position when at the main menu, but this will be fixed in an update soon. Generally you’d have to be in an active flight in order for Simlink to recognize the position.

Kind Regards,
Malte

1 Like

So I just spawned in after restarting the sim and simlink still says this
image

Roger that. Please send the latest log file over and we’ll have a look!

Kind Regards,
Malte

1 Like

simlink_2021-07-06.dlog (13.1 KB)

1 Like

Right. You seem to have the same symptoms as the user in the thread that I linked above. Are you sure that you verified that all paths were correct in the environment variables?

Also, if you made any changes to the paths, please restart the computer to make sure that they have their intended effect.

Kind Regards,
Malte

alright I will do a restart on my pc

Yes I followed every step in the message that you linked above

1 Like

And were any of the paths incorrect? Or did everything look like it should?

Kind Regards,
Malte

the 3 paths were not there yet, however I inserted them and saved everything

image
now it looks like this @skysail

Yesss the PC restart did it!

Thank you very much for your help Malte!

1 Like

You are most welcome, enjoy and have a nice evening!

Kind Regards,
Malte

1 Like

Now I can happily continue my C172 trip through Scandinavia. I will be sure to visit your hometown Stockholm : )

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.