Identity API not working


I can login in website using my credential and it works but if I try to login within MSFS using the navigraph icon in the MSFS toolbar at the top of the screen when I try to sign in (using the same credential) I received a message invalid password or email.

The MSFS navigraph is sending me to (.etc) and if I login using my credential it does not work.
I tried using the troubleshooting on the page using the QR code and a mobile or the and I cannot login.

Can you help, please?

1 Like

Exactly same issue here. And I wanted to say that all these years it was all-fine, but suddenly today when I opened MSFS I was asked to login and I am told that the email/password are incorrect when I can use the exact same credentials to login in the main navigraph website etc.

When I tried to use the QR code it even said that the code is linked to a different device…

Exactly the same issue for me. Anything from Navigraph about this?

1 Like

When i log into MSFS i can use my charts via the tablet and can log in on web browser. However when attempting to log in from the tabs at the top of msfs for navigraph it states the email or password is incorrect even though these are the same details i use for logging in via the web browser.

Please help.

1 Like

Same problem here, some of us have been reporting it here:

Hello everyone!

This was an oversight on our part, apologies. A fix is heading out as we speak!
Sorry for the inconvenience.

Kind Regards,


Hello again!

This issue has now been fixed. If you still see the same, please restart the flight and/or simulator!

Kind Regards,

1 Like

After previously trying multiple things, I can confirm that it is now working. Thank you very much for the fix, it’s appreciated! :slight_smile:

Thank you. I run a test and it does work now.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.