Identity Login Page Is Throwing Errors [Solved]

Hi Folks,

I launched the Center today and accepted a new update. It closed out, gave me prompts to install. No problem there.

Now when I launch the NavData Center, and I hit the blue Sign In button, it naturally switches over to the Identity API in a browser window. I sign in there, then get a prompt to use NavData Center to open these types of links. I agree. But then it just sends me back to NavData Center again with the blue Sign In button and we’re in this closed loop behavior.

Thoughts or recommendations please? Thank you.

I have this same issue right now. SimLink, Navigraph Charts, Navigraph Navdata Center for MSFS all hanging when attempting to sign in.

Updated - now the login is throwing an error.

@NAVData Richard?

Yep - it may be their authentication page is not working.

Yeah looks like it, I just got the same error message as you as well.

Oh, thanks let us check please …
Cheers
Richard

2 Likes

I can confirm I’m seeing the same error

1 Like

We are currently working on it … Standby folks. Currently no real login/authentification is possible … sorry

Cheers
Richard

6 Likes

Back again - should be ok for now, but we are still investigate the root cause.

Thank you very much for your patience
Richard

5 Likes

Thanks @NAVData Richard.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.