Having issues with Navigraph app on windows - error 0xc000007b

I have been having real hard time with the desktop application since the last 3/4 days - the app simply stopped launching on my windows 10 machine and throws a 0xc000007b (attached screenshot) error when I try to launch it.
looked everywhere to solve it but to no avail:

  • deleted the app and reinstalled (6 times !!)
  • redownloaded the VS_redis files (as advised in one of the posts here) and reinstalled both 64 and 32 versions
    I admit that I’m clueless now how to get it to work back.
    any help would be really appreciated.
    thanks
    Screenshot 2021-06-13 123616

Hi…,

Welcome.

I suggest a fresh start using exact procedure below :

Please disable any Antivirus and firewall. Uninstall AV if needed.

Please use only Windows Programs and Features to uninstall Simlink and Charts:

  • If they exist delete folders:
    c:\Users\username\AppData\Roaming\Navigraph\Simlink
    c:\Program Files\Navigraph\Simlink
    c:\Users\username\AppData\Roaming\Navigraph\Charts c:\Users\username\AppData\Local\Programs\Navigraph Charts
  • Download and install latest Charts .
  • Download and install latest Simlink .

If same problem please try again FAQ - FMS Error "api-ms-win-ctr-runtime-l1-1-0.dll" or "(0xc000007b)"

Please let us know how you get on.

Cheers
Ian

Hi Ian,

Thanks for the guidance.
I tried exactly to word the same steps like 6 or seven times. And followed the VC reinstall in all combinations all to no avail.

I’m at this point giving up on this thing as the last resort is to format my computer which I’m not ready to do.

Sad that this software is failing me for a subscription that I’m paying just for nothing.

Please tell me that there’s a way to get this work back again.

Thanks

Please try going back to a Windows Restore point when the system was performing correctly.

Cheers
Ian

Hi Ian,

I’ve tried all possible venues, but going back to a working restore point on windows is not an option for me - I use the same machine for other stuff and cant afford loosing any of the data it holds.
I was hoping for a support from you guys to fix this issue - but so far I’m only turning around.
isn’t there a fix that you will issue or something ? as far as I know I’m not the only one facing this kind of an error.

Thanks

Hi - Can you please help me out with fixing this issue ?
rolling back to a windows restore point hold too much risk for my other stuff, I can’t risk going down that path.
I’m still paying for my subscription and unable to use it as designed.

Thanks

Hi…,

If you search the web you will find many references to error 0xc000007b with suggested solutions. Beware some of these solutions have viruses at their sites. It is an issue on your machine. We can’t test these solutions as we don’t have the issue.

I suggest you use Navdata Manual Installs for your addons. This will update your navdata.

If you need help, please advise which addons you wish to update.

Cheers
Ian

Hi, after yesterdays’ Windows 10 update the error 0xc… has affected me. Are there any more effective solutions besides those above which can remedy situation? I did all recommended steps more than 5 times with no result.

Hi…,

Welcome.

Unfortunately this is a Windows issue on your machine. Please see FAQ - FMS Error "api-ms-win-ctr-runtime-l1-1-0.dll" or "(0xc000007b)".

If that doesn’t resolve it, then try restoring Windows to a Restore point before the update.

Cheers
Ian