FMS Data Manager stay on "Update your data index..."

I’m using Windows 10 Pro (updated) and X-Plane 11 installed on C: drive.
Launching the app, it “crashes / remain” (the app is still live, but nothing happens) on the “Updating your data index…”; after some seconds appears the CLOSE command, but it doesn’t find any addons, any installation, anything…
Also the SCAN finishes in few seconds, say it didn’t find anything
Up to now the app worked always well; I tried to uninstall it and re-istall it, I tried to delete the c:\ProgramData\Navigraph\FMSClient (it re-created it from the beginning, asking me for credentials), but still it doesn’t work



I suggest a fresh start using exact procedure below:

Please disable any Antivirus and firewall. Uninstall AV if needed.

If you have backups of previous AIRACs you wish to keep, backup c:\ProgramData\Navigraph\FMSClient\backup

Use Windows to uninstall FMS Data Manager. Specifically:

  1. Press Start and open Apps & Features.
  2. On the right hand side, open Programs and Features.
  3. Find Navigraph FMS Data Manager in the list, select it, and press the Uninstall button above.

If they exist, delete folders:
c:\ProgramData\Navigraph\FMSClient and c:\Program Files (x86)\Navigraph\FMS Data Manager.

Download and install latest FMS Data Manager .

Please let us know how you get on.


Hi Ian,
many thanks for your answer; actually I already did that (reading other posts) and I have just complete the procedure you suggested (uninstalling and deleting manually the c:\programdata\navigraph\FMClient, and finally re-download the client and re-installing it).
It asked me again for credentials, it started and now it is still on “Updating your data index…” (with “Close” near).
I’ll let it so all the night and tomorrow morning I’ll check if something is changed, but in the same last trial, the day after I found it in “Updating… state”

In the log file, I find a lot of items says “[D:\Development\Repositories\Navigraph\fmsdata-manager\NGFMSClient\downloader…”, but on D: drive I don’t have any “\Development…” folder structure… is it correct anyway?

Many thanks in advance

Hi Ian,
I have solved out the problem, that was A PERIMETRAL FIREWALL (not the windows firewall) setting; I have still to investigate exactly which protection setting and I’ll let you know
After changing the PC network parameters in order to use the second firewall appliance where the protection settings are different, it worked perfectly.

I tried it, because in the log file I found some “suspicious” items like that:

[2021-03-28 03:47:50][Web Service: 1][0] - CHttpDownloadWorker::downloadCurrentPiece [D:\Development\Repositories\Navigraph\fmsdata-manager\NGFMSClient\downloader\chttpdownloadworker.cpp:126]: request byte range: bytes=0-102935
[2021-03-28 03:47:50][Web Service: 6][0] - CHttpDownloadWorker::slotError [D:\Development\Repositories\Navigraph\fmsdata-manager\NGFMSClient\downloader\chttpdownloadworker.cpp:249]: Network socket error 299. Unable to proceed.
[2021-03-28 03:47:50][Web Service: 1][0] - CHttpDownloadWorker::downloadCurrentPiece [D:\Development\Repositories\Navigraph\fmsdata-manager\NGFMSClient\downloader\chttpdownloadworker.cpp:126]: request byte range: bytes=0-102935
[2021-03-28 03:47:50][Web Service: 3][0] - CHttpDownloadManager::slotTaskFinished [D:\Development\Repositories\Navigraph\fmsdata-manager\NGFMSClient\downloader\chttpdownloadmanager.cpp:207]: Task finished. Cleaning up…

Many many thanks

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.