FMS Data Manager Publisher Blocked

Hello All,
By mistake I cancelled my Navigraph subscription before the end date.
Subscription all fixed now BUT when I try to run latest version of “fms data manager.exe” Microsoft tells me “This Publisher has been blocked from running software on your machine”.
Am running W10.
It looks as if Navigraph may use some sort of ‘certificate’ which in my case may not have been renewed.
Anyone any ideas ? Thanks,

Hi Mike,


I suggest a fresh start using exact procedure below :

Please disable any Antivirus and firewall. Uninstall AV if needed.

Use Windows to uninstall FMS Data Manager. Specifically:

  1. Press Start and open Apps & Features.
  2. On the right hand side, open Programs and Features.
  3. Find Navigraph FMS Data Manager in the list, select it, and press the Uninstall button above.

If they exist, delete folders:
c:\ProgramData\Navigraph and c:\Program Files (x86)\Navigraph.

Download and install latest FMS Data Manager to the default location.

Please restart computer.

Please let us know how you get on.


Thanks. Will do that and ‘report back’ tomorrow.

Hello Ian,
Have had a look at that issue this evening.
I carefully followed all your instructions but same result.
There were some additional ‘references’ to Navigraph in Users/mikeo/Appdata/Roaming that you didnt refer to - I deleted them in addition to the ones you referred to.
I am reasonably computer literate but so far I cannot see anything has changed except the ‘reinstatement’ of my subscription at your end.
I have found this on the internet so it seems not to be an uncommon problem - I havnt tried any of their ‘solutions’ just yet.
Just paste a copy this url into a browser and check it out - it specifically refers to ‘expired digital signatures’.

The Digital Signature of today’s downloaded ‘navigraph fms data manager.exe’ reads :

Name of Signer: Navigrapgkommanditbolag

Algorithm : sha 1

Timestamp : 22 April 2021 03:09:36

Thanks for your help so far Ian - but it looks like I need more help !

Am running W10 Professional but like most people I am vulnerable to MS updates !

Mike Ody

Hello Ian,
An update.
I have just found a workaround to add latest NavData to my Airbus.
It’s not very satisfactory but it works.
I downloaded the manual install file onto a flash drive.
Then if I run the manual install .exe from the flash drive (not from the main PC) it installs OK.
I really dont understand why.
My first thought it could be a W10 update causing the issue but then I am able to run other imported non flight sim .exe files without a problem.
Given I have already deleted everything to do with Navigraph and then reinstalled and unsuccessfully tried again I really dont know why my PC doesnt like Navigraph !
Mike Ody

Fixed it.
It was a UAC problem - listed in that link I included a few emails ago.
I had to temporarily stop UAC, install the Navigraph data manager, and then restart UAC again.
All good now.
I dont know whether i will have to do the same for the next update - will cross that bridge then.
Thanks for help,
Mike Ody

Hi Mike,

You are welcome. Thank you for the update. Glad it is resolved.

Happy flying.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.