FMS Data Manager Not Updating

Hello, I have been trying many times to update navdata for XP12 and its addons. This has happened for months on end now, regardless of AIRAC cycle or navdata type. It goes through the download cycle, and instead of displaying the current AIRAC in green, it goes back to “ready for update”. I also tried running it in admin mode to no avail. Any help please?


In FMS Data Manager Settings, Make sure your have the latest Version

If not, please uninstall, download and run FMS Data Manager.

In FMS Data Manager Settings, Check you have the correct X-Plane 12 path.
In Addon Mappings , select and Remove X-Plane 12 and X-Plane 12 addons. Press Scan. If X-Plane 12 and X-Plane 12 addons are not detected, use +Add to add them manually.

In Addon List select and Update X-Plane 12 and X-Plane 12 addons.

Please let us know how you get on.


Seems this was the issue. I recently moved my XP over to a new drive and did not change that on the FMS data manager. Will try again and see how it goes

Thanks for the quick response, it worked.


You are welcome. Glad it is resolved.

Happy flying.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.