CTD when running Navigraph with AMD 7900 XTX

I’ve had several driver timeouts causing a CTD in MSFS. The common denominator was Navigraph. When not running Navigraph MSFS runs fine, but if Navigraph is switched to as active window or started when the game is running, I immediately get a driver timeout and crash to desktop.

1 Like

I second this. I did the Charts update on Saturday I think, and I have the Same issue with a 7900XTX. When loading either MSFS or Charts, if both are open at the same time it immediately triggers a driver timeout, MSFS Crash, and the Charts Application 3D Rendering Engine goes blank until its restarted.

I’ve reverted to using the Charts web app until a fix is found.

I just picked up a 7900xtx and the exact same thing is happening to me.

Edit: Even using the online charts crashes my game. Happened when I turned on flight following, which may or may not be related.


We don’t have this specific card to test. Navigraph only uses standard components in development of our apps, perhaps importantly here is Mapbox for the vector map.

Have you applied the latest driver updates? Or could you revert to some older driver?

Can you play around with the settings for the graphics card to see if you can narrow down the issue?



This is the only driver I have installed, which I assume is the latest since I just got the card. Since this is such a new card, there are only 2 other previous drivers.

GPU - AMD Radeon RX 7900 XTX - Primary/Discrete
VRAM - 24560 MB - GDDR6 2500 MHz
Driver Version -
AMD Windows Driver Version - 31.0.14000.62003
Direct3D API Version - 12.1
Vulkan™ API Version - 1.3.232
OpenCL™ API Version - 2.0
OpenGL® API Version - 4.6
Direct3D® Driver Version -
Vulkan™ Driver Version - 2.0.247
OpenCL® Driver Version - 31.0.14000.62003
OpenGL® Driver Version - 23.01.221108_f51c4a4
2D Driver Version -
2D Driver File Path - /REGISTRY/MACHINE/SYSTEM/CurrentControlSet/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0001
UI Version - 2023.0106.2322.1953
AMD Audio Driver Version -
Driver Provider - Advanced Micro Devices, Inc.
Windows Edition - Windows 10 Professional (64 bit)
Windows Version - 22H2


It really sounds like a bad driver, and unfortunately we are not able to do anything about it as this is really a specific issue to this particular graphics card and driver. I’d suggest you report it in the AMD forum, and as I can tell there are already quite a number of issues reported with this card/driver.

Try the Charts Cloud web app in your browser in the meanwhile and see if that works. Or use our iPad or Android app if you have a tablet available.

Kind regards,


The charts browser app also causes the CTD (when on same pc). Happened when I turned on the flight following in the browser app.

I will try a tablet and see.

I experience the same. I also have an RX 7900 XT.
If MSFS 2020 is running, as soon as I move the map in Navigraph, the sim and Navigraph crashes.

This does not happen with X-Plane (12) and Navigraph. Here everything works just fine.

Best regards,

1 Like

Out of curiousity: Have you tried DX12 mode in MSFS2020?

I just did, and now the crashes are gone :-S

1 Like

I did not try that, but I already replaced the card with a Nvidia and crashes are gone. Too expensive of a card to be a beta tester. But glad you figured out a workaround.

I cannot run Navigraph on my desktop, only on a tablet because whenever I zoom the Navigraph map MSFS freezes then crashes. I’m not sure if it was an update when this changed, but it crashes every time. If I run Navigraph on a tablet no problem. Windows11, Ryzen9, AMD7900XT. MSFS2020 flying CJ4.

The crashes seem to be eliminated if I use DRCTX12 with my AMD7900XT. Works as it normally did before I got this video card so far.

It’s not specific to Navigraph, it’s some weird interaction between MSFS (probably the stone-age Safari browser parts they’re using for UI) and the system. The same also happens when running the web version of Navigraph in Firefox or the Volanta app and trying to move or zoom the map in either.

If you want to join the hype train of ignored posts in the AMD forum:

same problem here. Also 7900XTX. I tried it in different PCs - always the same problem. DX12 somewhat helps but not fully. The MSFS survives the driver timeouts but Navigraph Charts still crashes.

I haven’t had Charts crash since switching MSFS to D3D12.

I am seeing an issue where the app will eventually break after sitting there with no interaction for a longer time and have a big blank screen in the viewport requiring an application restart or even reinstall to restore the affected area of the map. I’m not sure if that’s related to a previously reported caching issue, or down to the driver shenanigans.

Has anyone had a crash since AMD came out with version 23.4.1?