CPU usage almost 100% when moving map

Admittedly I’m using Navigraph on an older PC than my main one but the CPU is almost 100% when using the Windows PC app. The old version worked perfectly. Appreciate any suggestions as it’s now so sluggish it’s become unusable.

AMD FX - 8120 3100 Mhz CPU
AMD Radeon 6900 GPU

I know these specs are low but I only use this PC for less intensive applications. However the old version of Navigraph worked perfectly before this update. Would it be possible to give customers a choice between the old & new versions. Thanks …

Just want to add I notice overall very high CPU use on Navigraph 8, I run all my sim tools in a WIndows 10 VM hosted on XCP-NG (xen server more or less), 32core/64 thread broadwell 3.5ghz cpu’s, 128GB ram, flash array. I this server is very underprovisioned and not busy at all, the last navigraph had no problems, but this one its using 75% of the 6 threads i have assigned to this machine and goes to 100% when i move the map.

I’ve managed to get it to run reasonably fast now using the Firefox browser. I’ve tried every other option, Windows App, Chrome, Edge & Opera browsers etc but it was so slow it was unusable. Thankfully the Firefox browser works for me, not perfect but definitely much better.