Charts become very slow

I have been using Navigraph charts for a long time now and never had a problem. In the last few days I have had repeated problems where the charts have been very slow to load and on occasions say there is no internet connection but I know there is as mine is very good. Also all other sites are just fine.
The problems range from the main maps taking a very long time to fully load and the individual airport charts also taking long periods or just getting a black screen.

Hi Tony,

Welcome.

Given yours is the only report, this suggests an issue on your machine. I shall assume you also have Simlink installed

I suggest:

  • See FAQ - Simlink Install and Systray
  • In Navigraph Simlink Plugin Settings, for your FS entry press Uninstall Simlink.
  • Use Windows to uninstall Simlink and Charts
  • If they exist delete folders:
    c:\Users\username\AppData\Roaming\Navigraph\Simlink
    c:\Program Files\Navigraph\Simlink
    c:\Users\username\AppData\Roaming\Navigraph\Charts c:\Users\username\AppData\Local\Programs\Navigraph Charts
  • Download and install latest Charts .
  • Download and install latest Simlink .

Please let us know how you get on.

Cheers
Ian

Thanks Ian
Well the charts are fine now. I did find I had two versions of Navigraph installed and so perhaps an update had not taken off the old one?
The Simlink worked ok but did disconnect twice on a 2 hour flight. The internet was fine my end and so not sure why that was. It did reconnect when asked.
Thanks again
Tony

I thought I would update this thread. On Sunday I was having huge problems getting maps to load because it said there was no internet connection (but there definitely was). I tried downloading anew as before and the download took hours to download. Obviously there was something wrong with the Navigraph site I thought!
Monday morning I tried again - same result! Then suddenly I recalled that I had used the Avast “free trial” Clean Up app to mend broken registries, etc, etc on Sunday. I opened it up and “undid” all the “clean up” actions it had taken then I was able to download Navigraph again and it worked perfectly.
This app had basically slowed my PC almost to stop. Especially internet connections.
My advice is DON’T use these apps unless you have sufficient expertise to understand exactly what they are doing when they “clean up” your PC!